This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 3 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
June 6, 2019 at 6:42 pm

allanK

Hello,

I have a huge problem, I just can't explain...
I use Xenia Hotel theme ().
Default language is English. Translations in French.
As soon as I enable WPML and translate the content of Theme Options text values (for instance: copyright text, text in the header...) the translation replace the original text.

I give you an easy exemple to understand the issue.
If I write "Website created by..." in Theme Options for the copyright text, and write "Site web créé par..." as the French translation...
"Site web créé par..." will be saved as theme option default copyright text. "Website created by..." will disappear.
Strange thing... In the mysql database, in the theme option live from the options table, the default text in English will still be saved there.

I talked for a long time with the theme vendor, he has no idea why this problem happens.

FYI, the ftp doesn't work. That's why I haven't provided you the access below. I'm still waiting for a fix from my client. :/

June 7, 2019 at 12:35 am
June 7, 2019 at 12:36 am #3972577

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above, thanks.

July 1, 2019 at 7:52 am #4116197

allanK

Hello,

Sorry for the late reply. My client was in holiday, then it was my turn...

I still have the problem.
I created another backup website (same password):
hidden link

I disabled most of other plugins... and the probelm is still there.
Everything is messed up.

Do the following test, you'll see:

- Go to Theme Options > Nav Mini Tools and change the custom markup text & save
- Go to Theme Options > Content > Single Room Post and change the Amenities Index labels (not the slugs) & save.
- Check your modifications on this page for exemple : hidden link
- Now go to WPML String Translations & search for terms you edited. I suggest you go for the Custom Markup text... Usually the English defaut text is NOT the one saved in Theme Options (it's an old value I saved long ago).
- Make some changes for the translations & save.
- You can also test with saving the main menu.
- And check the previous link.
- When I do it, the French translation are displayed instead of the english texts saved previously in Theme Options.
- If it's the case, go back to String Translations, you'll see that the French Translations have become the English default texts.

I've spent dozens of hours on this issue and whatever I do... the problem ALWAYS happens.

July 2, 2019 at 12:16 am
July 2, 2019 at 12:17 am #4122551

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

July 2, 2019 at 7:13 am #4124533

allanK

My bad. You can try again to log in the new backup website. It should work now.

July 3, 2019 at 12:52 am #4130727

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your website using the stagging test environment at: hidden link. I couldn't replicate the mentioned issues, here are the steps I followed:

1 - I entered a custom html markup for your 'Mini Tool > Custom Markup' option from your WordPress Dashboard > Theme Options > Header > Nav Mini Tools settings. I translated this markup in your WordPress Dashboard > WPML > String Translation under the '[plethora_options]ple-header-navminitools-custom-markup' key from the 'admin_texts_plethora_options' text domain. The issue is not replicable here as you can confirm at: hidden link and hidden link

2 - I renamed the 'Amenities Index' labels from WordPress Dashboard > Theme Options > Content > Single Room Post > Amenities settings and translated them in your WordPress Dashboard > WPML > String Translation under the '[plethora_options][ple-room-amenities-index][title]*' key from the 'admin_texts_plethora_options' text domain. The issue is not replicable here as you can confirm at: hidden link and hidden link

Please, let me know if you have the same results or if I am missing any concept here. Thank you for your collaboration and patience, have a nice day.

July 3, 2019 at 8:17 am #4133051

allanK

I'm quite lost...
For once, I've tried to made the translations using Chrome (instead of Firefox) to make some translations. And it worked like a charm.
For a moment, I thought the problem was coming from Firefox...
So I made the SAME tests on the production website hidden link
And... the same problem occured.
Actually the problem is quite simple. The data saved in theme options are not properly saved in the database (don't ask me why the texts are still showing up when I reload the theme options pages, I have no clue where the texts are saved then).
Check out the screenshots.
For the button, the English text is wrong in string translations.
For the amenities, the english text is not even found!!!!

FIY, I also disabled most of the plugins just in case. It made no difference!

July 4, 2019 at 2:34 am #4139655

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. So in this case you replicated the issue in the provided stagging environment I ran my tests, right? If so, it is really weird I didn't loose my editings during my tests. Please, confirm, so we can proceed with further investigations. Thank you for your collaboration and continued patience, have a nice day.

July 4, 2019 at 6:06 am #4140393

allanK

Since my client's patience is not mine... I decided to put live the staging website in order to replace the production website. Everything seems to work just fine.
But to answer your question, yes, the environment was the same. Same server, same WP settings, same plugins, same browser...
Just in case... did you do anything on WPML settings???

July 4, 2019 at 5:41 pm #4145587

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. It is really weird and complex to debug as both websites come from the same environment, I only can imagine here some sort of cache interfering in your production website but not for the stagging one. I didn't change any settings in your website, I just edited the theme options values and string translations values and no error was replicated. It also confirmed we don't have an issue coming from WPML's side as everything is working properly with a fresh created website. Please, consider investigating any cache related issue as a possible explanation of your issue here. Have a nice day.