This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 3 voices.

Last updated by Dat Hoang 2 years, 7 months ago.

Assigned support staff: Dat Hoang.

Author Posts
October 18, 2016 at 2:34 pm #1117888

Dat Hoang

We have the errata about this https://wpml.org/errata/cannot-activate-option-translate-theme-plugins-using-wpmls-string-translation/

There has a workaround.

I hope that does help for you.

October 21, 2016 at 12:41 am #1119984

The J

Unfortunately the workaround didnt work. The options still doesnt get saved.
Please advise, we need this to be fixed asap!

I will not start running SQL queries on a live website just like that, I didnt develop the plugin and support should help more than just with words.
It would be appreciated if you could provide a solution that actually works.
Either fix the issue with the option or provide a faster/easier way to batch delete all the useless strings that the plugin automatically registered (there is a register all, but not delete all?!)

October 24, 2016 at 3:38 pm #1121865

The J

Any updates??

October 25, 2016 at 10:04 am #1122424

Dat Hoang

You can either choose the temporary solution at https://wpml.org/forums/topic/theme-plugin-translation-option-keeps-resetting-not-saving/#post-1116465 or comment out this line on \sitepress-multilingual-cms\ajax.php

 
        if($icl_tl_type == 1) {
            do_action ( 'wpml_scan_theme_for_strings', true );

If not, please wait for the next release. Based on our developer info, we will improve in the next release.

However, we can not say the exact date of the next release.

October 25, 2016 at 11:21 am #1122527

The J

The workaround doesnt work, but commenting that line worked.
Thank you

October 31, 2016 at 3:29 pm #1126651

The J

Just wanted to point out the fact that when activating a new plugin (Toolset Types), we keep getting errors (probably all linked to the previous one).

Fatal error: Out of memory (tried to allocate 262144 bytes) in /wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-db-translation-retrieve.php on line 170

Fatal error: Out of memory (tried to allocate 262144 bytes) in /wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-db-translation-retrieve.php on line 165

Please make sure that new plugins don't get automatically scanned (especially if option "scan automatically" is OFF!)

December 15, 2016 at 10:13 am #1160986

Dat Hoang

This issue should be fixed in the recent release WPML 3.6.x.
Please update it. I'm closing this ticket. Please open a new ticket in the case you have any issue.

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).