This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Otto 1 year ago.

Assigned support staff: Otto.

Author Posts
September 14, 2018 at 12:17 am #2733301

denisG-15

Hello!
There was a problem.
The site needs to be translated into 7 languages.
To do this, a subscription to the WMPL was acquired.
I can not translate Appointment notifications.
Tell me, please, how to do this?

hidden link

[REMOVED]

September 14, 2018 at 2:25 pm #2735707

denisG-15

Hello

September 15, 2018 at 10:39 pm #2738071

denisG-15

The problem is on the blog page.
Below the page there is a field with a shortcode.
If the Read next change value is changed in all languages.
The screen was attached.
In the translation of lines this shortcode does not fall.
I also attach the code that is responsible for displaying this information.

Template pregnancy

hidden link

hidden link

hidden link

September 15, 2018 at 11:51 pm #2738103

denisG-15

<!-- Readmore Style-->
<div class="custom-box">
<div class="column one-sixth">
<label><?php esc_html_e('Read More Button','pregnancy');?></label>
</div>
<div class="column five-sixth last">
<?php $v = array_key_exists("blog-readmore",$tpl_default_settings) ? $tpl_default_settings['blog-readmore'] : '[dt_sc_button title="Read More" style="" class="dt-sc-read-more"]';?>
<textarea rows="1" cols="100%" id="dttheme-blog-readmore" name="dttheme-blog-readmore"><?php echo esc_attr($v);?></textarea>
<p class="note"> <?php esc_html_e("Enter button shortcode",'pregnancy');?> </p>
</div>
</div><!-- Readmore Style End-->

Where to add GET?

September 16, 2018 at 11:35 am #2738814

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Please, apologize for the delay in answering. I will take care of this ticket and reply time will be shorter now.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

I removed the credentials you've shared. Take into account that this is a public forum and they have been exposed. I suggest you change them.

For the "Read more" string, try the following please:
Provided that you have the "WPML String Translation" AddOn installed please follow these steps:
- Go under "WPML -> Theme and plugins localization".
- Make sure that "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" is active.
- Scroll down to "Strings in the theme" and click on "Scan the theme for strings".
- Scroll down to "Strings in the plugins", select the plugin you want to scan and click on "Scan the selected plugins for strings".
- Once you followed the above steps go under "WPML -> String Translation". All strings available for translation should display in the table you see there.

Do you see them? If yes, all you need to do is click on "translations" next to each string you want to translate and enter + save your translations.

Documentation:
https://wpml.org/documentation/getting-started-guide/string-translation/

Regarding the email text. As it seems to be a theme option, so, it's possible that those strings have been recognised but not associated yet to the String Translation panel. For this, could you go to:
- WPML > String Translation
- Click on the blue link at the bottom of the page: "Translate texts in admin screens »"
- Look for un option similar to "theme_mods_voice", or something like that. Here you should find all strings associated to your theme options.
- Check the checkbox for your strings of interest.
- Click on the button "Apply"
Now, all your selected strings, should appear in the String Translation panel

Reference :
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Let me know if this helps, please.

Kind regards,

Otto

September 16, 2018 at 7:46 pm #2739152

denisG-15

Did as you write, the lines were not added. As far as I understand, I need to add my short code - it is not added
[dt_sc_button title = "Read more" style = "" class = "dt-sc-read-more"] .
I can not find him.

hidden link
hidden link
hidden link

September 17, 2018 at 11:43 am #2740739

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

From your latest screenshots, I can see that the shortcode is added to a page custom field, right?

So, what we have to do is to make this field translatable, and then you will be able to translate it in the page translation.

To do so, go to edit the original page. At the bottom you will find a section: "Multilingual content setup". Go to Custom fields and set the one that holds the shortcode to "Translate".

Then, make a small update in the original page and edit the translation. In the translation, you should be able to translate the shortcode.

Let me know if this helps, please.

Kind regards,

Otto

September 17, 2018 at 2:21 pm #2741372

denisG-15

Hi/ Sorry? but not work/

September 17, 2018 at 2:55 pm #2741540

denisG-15

I do not know how, but the text has finally appeared. But it does not change the data page.

September 17, 2018 at 5:43 pm #2742116

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

To take a deeper look without interfering with your site I created a test site so we can check the issue there.

Can you please install the theme and reproduce the problem (just the minimum of elements to reproduce it).

To access the site, just follow this link:
hidden link

Thank you!

Kind regards,

Otto

September 17, 2018 at 8:19 pm #2742485

denisG-15

Hi Ready.
I can install demo data, if you need

September 17, 2018 at 9:37 pm #2742666

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks! No, it's not necessary the test data, for now, thank you.

I managed to translate the shortcode added in the theme admin options.

I scanned the theme and the required plugins. Then I was able to find it in WPML > String Translation, under the domain "admin_texts_pregnancy-opts". The strings have the English language so I change it to Russian. Then, I was able to translate it to the other languages.

Please take a look at the test site and let me know if it is working fine and if you manage to do the same on your site, please.

Kind regards,

Otto

September 17, 2018 at 9:55 pm #2742702

denisG-15

I also thought like you, what I found)) But no, the translation is not displayed on the site.
Attached a photo of your site

September 17, 2018 at 10:06 pm #2742728

denisG-15

Otto thanks!

September 17, 2018 at 10:17 pm #2742741

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

You are right. This translates the shortcode when the default options are used. But the theme allows overwriting these settings per page.

So, you need to translate this option per page.

I did the following:
-I went to WPML > Settings > Custom fields
-Clicked on "Show system fields"
-I unlocked "_tpl_default_settings" and set it to "Copy once"
-Updated the original page
-Then edited the translation and modified the shortcode text

Now, it is translated.

Can you please try it on your site?

Let me know your results, please.

Kind regards,

Otto

The topic ‘[Closed] Theme Pregnancy – Appointment Notifications – WPML not translate’ is closed to new replies.