This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by hugoW-5 4 years ago.

Assigned support staff: Przemysław.

Author Posts
October 5, 2015 at 1:15 pm #717977

homeL

I am trying to: copy theme settings also into translated pages

URL of (my) website where problem appears: hidden link

I expected to see:

Instead, I got:

October 6, 2015 at 11:23 am #718728

Przemysław
Supporter

Languages: English (English )

Timezone: Europe/Warsaw (GMT+02:00)

Hello,

My name is Przemysław and I will help you with this problem.

Most of the compatible themes with WPML save their options in wp_options and come with a file called wpml-config.xml.

This way WPML can register the theme options that need translations under String Translation.

However, Jupiter is an exception. This theme is integrated deeply with WPML, so you simply need to select the appropriate language from the admin bar to translate the options.

This link might be helpful: hidden link

If you would like to set something for all languages, you should switch language in the top bar of your WordPress to "All languages" when you are editing theme options.

If you have any further questions please do not hesitate to ask.

Thank you

October 6, 2015 at 12:06 pm #718764

homeL

Hi, and thanks for the answer. I tried this: export theme settings, activate wpml, import theme settings in all languages, and still doesn't work.

October 7, 2015 at 12:17 pm #719595

Przemysław
Supporter

Languages: English (English )

Timezone: Europe/Warsaw (GMT+02:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Thank you

October 7, 2015 at 1:06 pm #719648

Przemysław
Supporter

Languages: English (English )

Timezone: Europe/Warsaw (GMT+02:00)

Hello,

I used the page "Home" as the English translation of a front page. The problem was not in Theme options but in page options - for example, it had the slider disabled.

Please check if it looks okay (I have not translated any texts): hidden link

October 7, 2015 at 1:16 pm #719660

homeL

Yes, now it looks ok. My fault. Just another question: if i apply these settings to all the languages, it's normal that, for example, when i switch to french, it comes with all the basic WP settings (for examples widgets etc)?

Thank you

October 7, 2015 at 1:25 pm #719672

Przemysław
Supporter

Languages: English (English )

Timezone: Europe/Warsaw (GMT+02:00)

Hello Christian,

If you would like to share some setting between two different languages but edit other independently you should edit them for each language. But if you want to have the same theme settings for all languages, please follow this guide:

hidden link (Section "Setting theme options in a way that will work for all languages")

October 7, 2015 at 1:45 pm #719706

homeL

Thank you for the help, i will try this solution! Cheers and have a nice day!

October 17, 2018 at 7:47 am #2823587

hugoW-5

Hoi i have the same problem. It resets the theme settings. i have to ajust the typografie, header etc ect. And every language i will ad it's the same story. cant klik on the links above so please help me out here