This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Noman 9 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
December 29, 2018 at 7:41 pm #3042572

Steven

I am trying to:
I registered theme strings and translated theme and Marked them complete but they are not showing up on French site. See footer Address and Copyright message.

Link to a page where the issue can be seen:
hidden link

December 30, 2018 at 9:20 am #3042975

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please try to re-save the translation:

1. Go to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

2. Then again go to: String Translation >> Re-add your translated text >> and re-save. Make sure that "Translation is complete" checkbox is selected.

3. Please delete all sort of caches on your site / server cache if any / plugin cache / CDN cache (if any), clear browser cache and then see if it resolves the issue afterwards. You can also disable cache plugin temporary while you update this string.

Please let me know if this resolves your issue or you need further assistance.

Thank you

December 30, 2018 at 3:35 pm #3043294

Steven

Thanks, I tried this but did not work. I have no cache plugin or server cache. If I remove the copyright message from Transpress theme options it disappears but I can't seem to get the French translation to show after recreating the english one and then editing the string translation and marking it complete.

Same problem for all Transpress Theme Options.
The domain is: admin_texts_transpress_theme_options
The name is: [transpress_theme_options]bottom-footer-left

I still need help with this, Thanks.

December 31, 2018 at 7:11 am #3044219

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

January 1, 2019 at 10:11 am #3046811

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have debugged this issue, I tried enabling translation for copyright text with different methods we use but for some reason it is still not accepting translation. At this point I believe its due to an error in the theme code, this field might not be added in a standard way in this theme which is preventing it from translating.

I am going to debug further and will let you know if I find a workaround. Thank you for waiting on this.

January 1, 2019 at 10:42 am #3046838

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Further I have find out that you are using very old version of the theme v1.5. Please take full site backup and update theme to the latest version v1.7:
hidden link

I can see various critical updates including Redux Framework (Theme Options framework) update, so this will hopefully resolve the issue or let us apply the changes.

Thanks

January 5, 2019 at 9:07 am #3058791

Steven

I've updated the theme to 1.7 and all required plugins. I've also tried deleting the copyright string translation and recreating it. But this isn't working. What should we try next?

January 6, 2019 at 4:32 pm #3060504

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for the updates, I have tested this again and its still having the same issue. I have also checked with parent theme, its appearing to be some sort of conflict between WPML and the theme. I am going to escalate this to our 2nd tier support and will keep you updated as soon as we have some news.

Thanks

January 7, 2019 at 8:32 am #3061719

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Can you please send me latest TransPress theme? I need to reproduce this issue on a clean WP site. Next reply will be private.

The topic ‘[Closed] Theme Strings (ie. Footer Copyright message translations not showing)’ is closed to new replies.