This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Noman 3 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
June 17, 2019 at 1:21 pm #4035593

marcusM-22

Hi

I installed the theme "busyprof" and WPML. I managed to translate all the secondary pages I created but the hompage with all menus and widget are still in french. I cannot find the translation location on this page. Thanks for your help.

June 17, 2019 at 3:03 pm #4036439

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have tried to visit your site but it seems your site is in coming soon mode, could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Please follow below docs for translating widget:

Method 1: https://wpml.org/documentation/getting-started-guide/translating-widgets/

Method 2: https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

- Please follow our step by step guide for menu translation:
https://wpml.org/documentation/getting-started-guide/translating-menus/

- Please delete all sorts of caches on your site / server cache (if any) / plugin cache / CDN cache (if any), clear browser cache and then check the page.

If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

June 17, 2019 at 3:54 pm #4036807

marcusM-22

Hi

Thanks for your reply. I updated the Memory size and removed "coming soon" for a while.
The welcome page is impossible to translate. Is it due to the "theme" itself?

June 18, 2019 at 6:34 am #4040723

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please provide welcome page link.

Thank you

June 18, 2019 at 2:55 pm #4044589

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

WP login info that you have provided is not working here. Could you please provide me working login please. I have enabled private input box for your next reply.

Thank you

June 19, 2019 at 7:53 am #4049077

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I see your home page content is coming from Appearance >> Customizer section. So I have enabled Home page strings translation by selecting relevant checkboxes from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> busiprof_theme_options and hit apply button.

And added one section translation from WPML >> String translation and it showing correctly at frontend as you can see in the attached screenshot.

You can add remaining section translation from WPML >> String translation.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

June 19, 2019 at 8:32 am #4049563

marcusM-22

My issue is resolved now. Thank you!

June 19, 2019 at 9:08 am #4049843
marcusM-22

Hi

Sorry to disturb again, I cannot find the following text to translate 🙁

Thanks

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/how-to-translate-this-section/

June 19, 2019 at 12:34 pm #4051435

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

For this issue, I have created a new ticket since this is a separate issue. Here is the link to the new ticket:
https://wpml.org/forums/topic/how-to-translate-this-section/

You may mark this ticket as resolved and we will continue to work on the new ticket.

Thank you for your cooperation and patience.