Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Alejandro 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
April 13, 2021 at 12:05 pm #8525013

antonyS-5

There can only be 10 jobs per page, is there a way to change this?

April 13, 2021 at 12:22 pm #8525261

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi there,

I briefly changed the chat into a ticket because i wanted to give you a way to cancel all the jobs easily!

Go to WPML > Support > Troubleshooting > Reset professional translation state > check the box there and press the "Reset professional translation state" button and it will cancel all the jobs.

Beware though, you should first finish the jobs that are in progress because they will be cancelled to otherwise.

Regards.

April 13, 2021 at 12:24 pm #8525271

antonyS-5

I'd already tried this approach and it doesn't work

April 13, 2021 at 12:35 pm #8525313

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

So if you do that, it will not cancel the jobs? if you cancel them manually and refresh the page, does it remain cancelled or is it "opened" again?

Because that option mentioned before should cancel everything and this means that there miiight be a problem on your installation or a bug on our plugins then.

April 13, 2021 at 12:41 pm #8525333

antonyS-5

Manually cancelling works fine, it just takes forever.

The reset doesn't seem to do anything. This is on a vanilla install - v5.7. All WPML plugins up to date. I've tried on two separate installs and the behaviour is the same.

Based on previous experience I'm guessing a bug.

April 13, 2021 at 2:35 pm #8526383

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm trying to test this locally here and i see the same. i have asked our devs to check what's going on and to see if they can give us a workaround for you.

April 14, 2021 at 10:07 am #8533477

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok.

1) I asked about this and the option i gave you was once for all the jobs but in the recent updates it has been changed to work only for translation services jobs.

2) There's a workaround here:

Go to \plugins\wpml-translation-management\classes\menu\jobs-list\class-wpml-tm-jobs-list-script-data.php

in line 195

search for:

'pageSize' => 10,

modify that 10 into a 50 if you want.

Please be aware that if you set a high number, you can go into a timeout if your server settings are not enough to satisfy the request from this page.

Regards.