Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 4 voices.

Last updated by Diego Pereira 10 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
September 22, 2020 at 7:05 pm #7072551

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Sorry for the delay. I had some issues duplicating the website. The only option that worked was the Cloudways option, which we duplicated here: hidden link

After several tests, I found that the issue happens because the database is missing some columns:
- 'wrap_tag' missing from `wp_sd2_icl_strings`
- 'batch_id' missing from `wp_sd2_icl_translation_status`

I added the table using the following SQL queries:

ALTER TABLE `wp_sd2_icl_translation_status` ADD `batch_id` INT(11) NOT NULL AFTER `translation_service`;
ALTER TABLE `wp_sd2_icl_strings` ADD `wrap_tag` VARCHAR(16) NOT NULL AFTER `location`;

After that, the translation editor is working as expected. Could you please check and confirm that?

September 23, 2020 at 8:54 am #7077591

romainO-2

Hello,

The translation editor is now displaying well but it seems that translation modifications are not taken into accourt. Can you try please ?

Capture d’écran 2020-09-23 à 10.53.46.png
September 23, 2020 at 2:04 pm #7081175

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

It happens because the DIVI theme was disabled, so the shortcodes are not recognized by WPML anymore.

I did the following test:
- Activated Divi theme
- Did a small modification on the original page and saved
- Updated the translation (100% complete) and saved

The translations are corretly applied to the english page: hidden link (check "Test EN" strings).

Please let me know if it worked for you.

Kind regards,

Diego

September 24, 2020 at 9:40 am #7089043

romainO-2

Hi,

It's seems to be ok, thank you.
Can you then apply the same patch to the site hidden link ?
I have made a full backup.

September 24, 2020 at 12:36 pm #7091155

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sure. I already created the tables on hidden link. Now you just need to enable Divi > Update the original page >Update the translation.

Please let me know if it worked for you.

September 24, 2020 at 1:59 pm #7092391
romainO-2

Hello
Ok it seems to work.
Last question : I cannot find how to display de page url filed in the classic translation editor ? Any idea ?

New threads created by Diego Pereira and linked to this one are listed below:

https://wpml.org/forums/topic/split-there-is-a-problem-with-the-string-translation-table-in-your-site-4/

September 24, 2020 at 8:13 pm #7094353

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

As the previous issue has already been resolved, I will open a new ticket for this new one.

I will reply in the new ticket: https://wpml.org/forums/topic/split-there-is-a-problem-with-the-string-translation-table-in-your-site-4/

Regards,
Diego