This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I see two messages on my WordPress installation:

"There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you."

and

"WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed. Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem."

Solution: Please create a new ticket. Our support will solve the problem on your database. Relevant Documentation: https://wpml.org/forums/topic/wpml-is-telling-me-that-it-has-a-broken-table-that-needs-fixing/

This topic contains 10 replies, has 3 voices.

Last updated by ioanD 5 months, 1 week ago.

Assigned support staff: Marcel.

Author Posts
May 14, 2019 at 1:06 pm #3807029

mortenH-7

I've got a classic issue (it seems). Got this issue:
"There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you."

and this:

"WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem.

This warning will disappear once this issue is fixed."

May 14, 2019 at 4:16 pm #3809075

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Morten,

Thank you for contacting WPML Support.

First can you please try to fix the second message here? You will find the troubleshooting page under WPML -> Support -> Troubleshooting (it's a link). There, click on "Clear language information and repopulate languages".

Once this is done, we can fix the first message. Please do a full site and database backup before

Best Marcel

May 14, 2019 at 5:04 pm #3809335

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

OK thanks, I made your reply private as this is a public forum.

❌ Can you please confirm that you have a full site and database backup before I start to work on your database? ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Best Marcel

May 14, 2019 at 5:06 pm #3809367

mortenH-7

Ahh bummer! Thought this was the ticket :l Thanks. I can confirm its all fully backed up. And you can do what you want 🙂

May 15, 2019 at 2:32 pm #3817709

mortenH-7

Do you expect to have time to look into this today? I'm stalling in the progress as I cannot do much as no pages show up

May 15, 2019 at 2:42 pm #3817949

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Yes, can you please also add me your FTP credentials? I need to check also your functions.php. Thank You.

May 15, 2019 at 4:04 pm #3818625

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Morten,

Thanks, it worked. The database table "icl_strings" was correct in the database, so the two messages were just a false positive. I removed them manually from your "wp_options" table. Now it's solved.

Best Marcel

May 15, 2019 at 4:54 pm #3818963

mortenH-7

Perfect! Thank you so much for the help!

May 15, 2019 at 5:09 pm #3818997

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

You're welcome 🙂 Could you please mark the ticket as resolved?

Many Thanks

May 15, 2019 at 5:20 pm #3819029

mortenH-7

My issue is resolved now. Thank you!

July 9, 2019 at 5:23 pm #4173415

ioanD

I have the same problem, please help