Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 2 voices.

Last updated by Gnist Design 2 months, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
August 28, 2019 at 9:02 am #4472673

Gnist Design

Hi,
I just checked the old snapshot and I had no problems downloading it from a different browser (not logged-in). Both snapshots are viewable and downloadable. You will find the download-button in the top right corner when following the link.

Regards.

August 28, 2019 at 4:20 pm #4475869

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi, yes. i managed to download it, for some reason the first few times i tried to download it the download button was not there, and in its place a "view" button was there.

I already sent everything to our developers so now i need to wait on them.

Regards.

August 28, 2019 at 4:22 pm #4475879

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Oh, yes, one more thing.

Did you use a particular tool to create your bakcups? it has been taking so long because i have had to change all the database information to the new tables and redirecting all the links to the new ones (in the database) which took way more than i expected.

September 2, 2019 at 6:04 am #4494571

Gnist Design

Yes, I used InfiniteWP to create the backups.

September 3, 2019 at 9:35 am #4502931

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I'm changing the status of this ticket because after everything the problem kept happening after the update. i gathered all the most important details and our developer took a look and we had to send it to our WPML Developers team because we couldn't determine why it was happening.

I'll keep you updated when our developers tell us what's going on.

September 3, 2019 at 9:40 am #4502949

Gnist Design

Ok. Thank you for looking into this.

September 9, 2019 at 7:44 am #4534119

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok, here's what we need to do:

1) Return to the "before update" Installation.
2) in your database run the following queries:

UPDATE `wp_arj_icl_translations` SET
`language_code` = 'no'
WHERE `language_code` = 'nb'

then run this one as well:

UPDATE `wp_arj_icl_translations` SET
`source_language_code` = 'no'
WHERE `source_language_code` = 'nb'

create a backup and then update WPML. tell me if that solves the issue, please.

September 9, 2019 at 11:59 am #4536813

Gnist Design

Hi.

This did not solve the issue, I am sorry to say. It looks like we have to do a clean install of WPML and start over again from scratch.

September 9, 2019 at 2:18 pm #4537903

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Let me talk to the devs and wait a moment before erasing WPML ok?

In the meantime, can you check if the credentials you gave me before are correct? i'd like to access your site and try the fix (if you give me permission, of course) before you delete everything.

Let me know.

September 9, 2019 at 2:34 pm #4538053

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok, i have everything i need now and tested it . please let me know where should i make the changes. if you can return the site to the "before update" installation and let me know when i can access.

I enabled the credentials field just in case you need to change them, but if the ones you gave me at the beginning of the ticket are correct, then i'll make them there.

Just to make everything clear these are the steps that need to be done (i had missed a few before because i got confused on my local installation):

- Install the "before update" package
- Update WPML to the latest version
- Go to WPML > Settings > Site Languages. You need to recreate the languages manually (english, norwegian and the "sami" language)
- use "no" as the code for norwegian, since it was setup as "nb" before which is now deprecated (this could be the cause of the problem)

- Run the SQL queries i wrote above on the database again
-Activate string translation (just to remove the error message if you have it)

Check if things are ok now.

If they are not, let me know and i'll access the site and try to fix it myself.

Regards.

September 10, 2019 at 8:17 am #4542875

Gnist Design

The issue is now resolved, following your latest instructions. Everything is back to normal. Thank you for your time and efforts!