This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Bigul 3 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 21, 2019 at 4:45 pm

aldoA-3

Hello!

There's a bug with a language in my tours website.

The tour is not inheriting the first language data, for example:

- Original product (in english) has 3 selected images to display in a slider, but the PT-BR language product just display 1.
- The style doesn't works fine with the section "Itinerary"
- The gallery section doesn't work fine.

This only happen with PT-BR language, and the second language (ES) works perfectly.

Link to a page where the issue can be seen:

I expected to see: The PT-BR language works like ES language.

Instead, I got: Some bugs with PT-BR language.

Please I need your support as soon as possible. Also the theme support tells me that's a WPML issue, but I'm not sure with this.

Also I can't update the plugins because it takes error 500.

Please I really need your help!

Thanks.

Aldo

June 24, 2019 at 9:25 am #4075949

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Aldo,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. Sorry for the delay happened because of the weekend.

The Portuguese Product page is showing a JavaScript error in the browser console. Please check the attached image.

Therefore please share with me the WordPress debug.log (not WPML debug information) for more details. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

If possible, please upgrade to the latest version of WPML(4.2.7.1) after a full site backup and enabling the debug mode. Then check you are getting any error or warning related to WPML in the *debug.log* file.

--
Thanks!

Bigul

June 24, 2019 at 3:59 pm #4078463

aldoA-3

Hello Bigul, thanks for your answer.

Please, check the file debug log here: https://pastebin.com/8cCdJ4qL

I have tried to update the plugin at least 3 times, but it takes me an error (white screen), so I don't want to try this again... Tell me if you want the FTP access or WP Login access.

Thanks!

June 24, 2019 at 5:45 pm #4079033

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Aldo,

Thank you for the updates and Debug log information. Debug log is not showing any warning or error related to WPML. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

June 24, 2019 at 7:48 pm #4079607

aldoA-3

Hello again, Bigul.

Unfortunately it didn't worked for me...

I really need your help please.

Thanks!

June 24, 2019 at 8:14 pm #4079631

aldoA-3

I have created another language and this look ok. This looks a problem with portuguese language.

I think I'm going to do all again with PT-BR lang. in order to fix the problem.

But first I need to know how to delete all translations and products and data of an specific language. It's like a complete clean of portuguese language.

Thank you again Bigul.

Aldo

June 25, 2019 at 5:27 am #4081421

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Aldo,

Thank you for the feedback. I have a couple of requests before deleting the Portuguese posts and retranslating it again.

1) Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

2) Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

June 25, 2019 at 1:29 pm #4084935

aldoA-3

Hello again Bigul,

I've tried the steps but nothing happened.

I really apreciate your help, but I really need to fix this problem soon as possible, so I need to know how to clean the entire PT-BR language and translating it again.

Thanks!

Hope u understand.

Aldo

June 25, 2019 at 3:21 pm
June 25, 2019 at 4:55 pm #4086287

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Aldo,

Thank you for the updates. I am able to create a Duplicator package now. Please check the attached image. Will debug the issue further and get back to you soon. Please wait.

There is no special function to delete the posts from a particular language. Because the details are stored in different database tables. So I am checking about this is our team now.

--
Thanks!

Bigul

June 26, 2019 at 7:13 am #4089907

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Aldo,

The issue is existing after the initial debugging steps. Therefore I will forward the details to our second tier team for the expert opinion. We will get back to you soon. Please wait.

--
Thanks!

Bigul

June 27, 2019 at 12:54 am #4095399
aldoA-3

Hello Bigul

I have created a new language and replaced this for "portuguese", so please don't continue fixing the last error. Now I'm getting another error while translating two tours (screenshot attached). When I want to translate some details on the portuguese language, it takes me the error. Can you help me watching the error by yourself in my server?

Or tell me what can I do, please.

Thanks!

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-sorry-you-are-not-allowed-to-edit-posts-in-this-post-type/

June 27, 2019 at 1:32 pm #4100397

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Aldo,

Thank you for the updates. Please note, I have opened a new ticket for the Tour translation issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

The topic ‘[Closed] Third Language (PT-BR) is not working properly around the site.’ is closed to new replies.