This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Oscar Miras 6 months, 1 week ago.

Assigned support staff: Oscar Miras.

Author Posts
April 4, 2019 at 5:28 pm #3537271

antonD-13

Hi, thank´s for help.
Have another problem. I tored to enable this "You need to enable WPML's Translation Editor, to translate conveniently." But when I clicked on button, the appeared messege "This action is not allowed" also site is still loading, can see the content but the cicle instead of favicon is still loading. Pingdom show pretty fine score and loading time, but in real there is slow loading.

Thanks for help.

April 4, 2019 at 6:16 pm #3537633

Oscar Miras

Hi,

Please, go to WPML > Settings. Make sure that in the section "How to translate post and pages" the setting for "New content" is set to one of the Translation Editors. If not, select one of them and click Save.

In case it still does not work, I have requested access to your site. Please, provide some working credentials.

Kind regards,
Oscar.

April 5, 2019 at 6:16 am #3540813

Oscar Miras

Hi,

Yes, you should be able to choose any of the two editors. Notice that there are two separate sections: "New content" will set the editor for new pages, whereas "Content that was created with the WPML's classic translation editor" will be used for the previous translations created with the Classic Editor.

Please take into account that we have some detailed documentation about how to translate pages with the Divi Builder: https://wpml.org/documentation/theme-compatibility/divi-builder

Does this solve your problem? IF not, just let me know and I'll be happy to help.

Best wishes,
Oscar.

April 5, 2019 at 4:51 pm #3545953

antonD-13

Hi, I tried both possibilities, but before I firstly checked one of the options pages looked absolutly different. There was looking like in classic DIvi builder but now I can see only possibility of translation, not possibility to change the layout or content.

April 8, 2019 at 8:13 am #3555347

Oscar Miras

Welcome back,

To have a different layout in the translated version of the page, please follow these steps:

  • Create the page with Divi in the default language. Publish it.
  • Edit again the page in the default language. In the Document options, on the right side, switch off the option “Use WPML’s Translation Editor”. In the popup message “Use the WordPress Editor to translate:” select “This Page”.
  • In the Language meta-box, select the Duplicate checkbox, and then click on the Duplicate. This will duplicate the page in the selected secondary language.
  • Click on the pencil icon to edit the page in the other language. Be aware that sometime you may have to click “Translation (show)” to display it.
  • Notice now that you are in a duplicate page. The flag on the top-left corner has changed to the secondary language. Then, in Document > Language you must click on “Translate independently”. WPML will no longer synchronize this page with the original content, so whenever you make a change in the original page, the translated page may need to be updated as well.
  • Edit your page as usual with the Divi Builder. You should have the layout of your original page. Now you can modify it and publish the changes.
  • Now you should have your page translated to the second language with a different layout.

Related documentation:
https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

I hope it was useful your you. If you still need assistance, I’ll be happy to help.

Kind regards,
Oscar.