This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.59 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by tomyH 3 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
July 5, 2019 at 9:09 am

tomyH

Getting error and WordPress recommended safemode to see the issue. The issue is described on the attached file. I tried to reinstall newest version several times from https://wpml.org/account/downloads/ with no luck.

Please help me with this issue. Thanks!

July 5, 2019 at 10:04 am #4150083

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I've tried installing the plugin, but it locked me out from the website now. However this may be a good thing - we can now trace the error log to see what is behind this. Therefore, can you do this?

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Reproduce the issue - refresh the website, this should fill up the debug.log on each refresh - hidden link.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

https://codex.wordpress.org/Debugging_in_WordPress

Regards,
Bruno Kos

Regards,
Bruno Kos

July 8, 2019 at 8:31 am
July 8, 2019 at 10:02 am #4160785

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Indeed, I'm not able to get it working either. Even when I disabled all the plugins through FTP, I'm still getting "HTTP ERROR 500" error, so somehow I think that this is server related issue and not WordPress specific.
hidden link

Can you reach out to your hosting support, asking them if they have some information on what exactly is triggering this error, getting the site unresponsive? Because from the WordPress standpoint, there's nothing else we can try at this point.

Regards,
Bruno Kos

July 8, 2019 at 10:22 am #4161227

tomyH

I am getting this message: [Mon Jul 08 12:18:20.727660 2019] [mpm_prefork:notice] [pid 67117] AH00163: Apache/2.4.18 (Ubuntu) SVN/1.9.3 PHP/5.6.31-4+ubuntu16.04.1+deb.sury.org+4 configured -- resuming normal operations
[Mon Jul 08 12:18:20.727688 2019] [core:notice] [pid 67117] AH00094: Command line: '/usr/sbin/apache2'
[Mon Jul 08 12:19:43.566038 2019] [:error] [pid 112562] [client 2001:4661:dfc8:0:5c7:1c23:d7c4:215e:33447] PHP Fatal error: Can't use function return value in write context in /var/www/1/236520/www/wp-config.php on line 30, referer: hidden link

Does this help?

July 8, 2019 at 12:38 pm #4162435

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Is definitely helped - it pointed out that the issue was in wp-config.php file. It happened probably when you were pasting and uploading the lines of code I gave you, but they were not saved properly (see quotes), causing the PHP syntax errors in the very core of the WordPress installation.

I have fixed this now and I also see that WPML is now working. I've also increased memory limit for your site so that it is up to our minimum requirements.

There is also one thing I would recommend, and that is that you use the latest PHP versions. I see that you have PHP 5.6., But any version starting from PHP 7 will bring performance improvements and many other general improvements. This is something the hosting company should do it for you and you can confirm these values on the WPML -> Support page.

Let me know if there's anything else I can assist with related to this ticket.

Regards,
Bruno Kos

July 8, 2019 at 1:44 pm #4163143

tomyH

My issue is resolved now. Thank you very much Bruno!