This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by tamasV-4 6 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
March 8, 2019 at 11:33 am #3291734

tamasV-4

Hi,

or theme is Entrada, a feature rich theme. I prfere to have “This post is also available in” on pages and set it to appear on the bottom of pages, but it is multiplied on the dropdown content.

Is there a way to correct it pls?

Thanks in advance,
Tamas

March 10, 2019 at 9:18 am #3303409

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Did you add the language switcher somewhere in any elements or widgets?
Let me know the page url where you have this issue.

Regards,
Riffaz.

March 10, 2019 at 10:55 am #3303777

tamasV-4

Hi Riffaz,

thanks for working on my issue on the weekend.

The theme we use is a feature rich travel theme:
hidden link

The product page has several tabs where the This post is also available in.. appears several times, but I did not add any custom coding.
Sample URL:
hidden link

Please let me know if it can be solved via WPML or I need to contact the developer.

Many thanks,
Tamas

March 10, 2019 at 11:33 am #3303997

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You are welcome.

Are you sure the link you provided for your site is correct?
I see just this when I go to that link : hidden link

Regards,

March 10, 2019 at 2:26 pm #3304539

tamasV-4

Strange, I can see the content on that staging site.
I have added the credentials of our live site to my post.
Please try to login and you will definitely see it.
Currently content of both live and staging are identical, so if you elimintate the "test." prefix, you can check it.
Thanks

March 11, 2019 at 5:51 am #3307813

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

It is same with live site as well.

How to go to a English page form your default language site.
I do not see any English flag in your switcher: hidden link

Regards,

March 11, 2019 at 7:09 am #3308031

tamasV-4

Hi Riffaz,

sorry, now I set your account to "Display hidden languages"
I hope it helps

Best,
Tamas

March 11, 2019 at 11:09 am #3310049

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

It is still the same in live and test site.

I am setting the next reply as private.
Let me know your site login details to check this closely.

Regards,

March 13, 2019 at 3:19 pm #3335549

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you.
I see it now.
The correct url is: hidden link

It seems somehow your theme / plugins duplicating the language switcher.

Do you want to show the switcher only footer?
Did you try to remove switcher from widgets and add it to the footer and check? hidden link

Also, please disable all the third party plugins including your caching and security plugins.
Create the language switcher and check.

Let me know how it goes.

April 11, 2019 at 1:39 pm #3588379

tamasV-4

Hi Riffaz,

extremly sorry for not replying any sooner. Pls accept my apologies.

When it is set to display on the footer the footer is broken, so I decided that after we finished testing the site I wil disable it completely.

Thanks for your time and support anyway.
Best,
Tamas

April 11, 2019 at 1:44 pm #3588395

tamasV-4

My issue is resolved now. Thank you!