This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 3 voices.

Last updated by Yvette 1 year ago.

Assigned support staff: Yvette.

Author Posts
September 11, 2018 at 4:46 am #2722424

vanessaZ-2

I am following this tutorial: hidden link
when he clicked the plus sign beside French, it showed a side by side translation option.
I am translating english to German and when I click +, nothing like that appears. It just sends me to a new create a page post.

September 12, 2018 at 4:34 am #2726099

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us.

Usually, after you activate WPML and Elementor, a message appears to activate the Translation Editor.

If this does not appear, please follow the steps below:

- Click on the WPML > Settings > How to translate posts and pages
- Select the "Use the Classic Translation Editor"
- Click on the Save button

This will make the Translation Editor appear as it is in the video you've linked above.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

September 17, 2018 at 2:00 pm #2741270

vanessaZ-2

I was able to figure it out the first time, but then again when I tried doing the same steps on other pages, it won't copy the elementor page. And if it did copy, it only copies the site description, but not the content. 🙁

Can you please send me a bulleted list of how to to know what to do to make a German page for each page available? What I gather is...

1. Go to the page
2. Select the + sign beside German
3. It should load the spinifexit.com/de version... but it doesn't this time around. I was able to figure out the home page, now trying to do the rest of the pages but it's not working again.

Really appreciate the help.

September 17, 2018 at 2:08 pm #2741308

vanessaZ-2

Also this one. It copied the content, but not the elementor layout. 🙁 how can i fix this?

September 17, 2018 at 11:13 pm #2742774

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for the feedback. How are you trying to translate your website? Are you trying to use Translation Editor? If so, you should not edit the secondary language directly with Elementor, as you show in your last screenshot.

Please see our step-by-step documentation of how to translate Elementor using Translation Editor: https://wpml.org/documentation/plugins-compatibility/elementor/

By following the steps above, you should edit the pages in the secondary language only using the Translation Editor and not accessing the Elementor page.

Following the steps in our documentation, you still can not translate correctly?

Thank you.

September 18, 2018 at 6:24 am #2743647

vanessaZ-2

I actually did exactly that. The page I am translating is: hidden link When the German page was created, it only showed the attached image. There is more content in the original page VS what it captured.

September 18, 2018 at 6:25 am #2743659

vanessaZ-2

I cannot do the Scenario 1 again for this page since I cannot delete this either. See attached.

September 18, 2018 at 10:07 am #2744335

vanessaZ-2

Likewise. I've tried editing the Solutions page. The translation is already saved, as you can see in the screenshot. But the german version only changed the title. the content is still the same.

However, when I edit the content directly in the elementor page, it reflects properly. Can we just edit directly from elementor? Please also check previous issues filed about a page not copying the elementor format. thank you!

September 19, 2018 at 8:01 am #2747657

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 20, 2018 at 7:08 am #2751020

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. It looks like you're using some plugin (or custom code) to remove menu items.

For example, with the user you created for me, I can not see the "Settings" pages of WordPress, nor the "Translations" page of WPML. I'll attach an image for you to see.

To be able to check what may be happening, please could you allow full access to the pages?

Thank you.

September 20, 2018 at 7:18 am #2751108

vanessaZ-2

Hello. Full access granted (admin permissions). Thank you.

September 21, 2018 at 5:03 am #2754035

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. When I try to access your site the message "Not Allowed" appears after I added the credentials. I'll attach an image for you to see.

Please, could you check? If necessary you can edit your private message above, which is displayed highlighted.

Thank you.

September 21, 2018 at 7:00 am #2754095

vanessaZ-2

Our IT recently added an HTTPS certification and now even I can't log in. I'll revert to you when this is resolved. thank you.

September 21, 2018 at 7:18 am #2754163

vanessaZ-2

Can you try again, please? Our IT fixed it. 🙂 Thanks!

September 25, 2018 at 6:12 am #2762557

vanessaZ-2

Hello. I haven't heard from you.

There are a couple of pages that we already completed the translations and they're in English again? 🙁

hidden link

Is an example. When we edit using the block form, it shows 90% of the content in one box only. It doesn't follow the formatting.

If I try to edit with Elementor, as I've shared previously, it won't load.. 🙁

The topic ‘[Closed] This tutorial is different from console’ is closed to new replies.