Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 3 voices.

Last updated by Yvette 1 year, 10 months ago.

Assigned support staff: Yvette.

Author Posts
September 25, 2018 at 6:15 am #2762560

vanessaZ-2

Now I'm editing it straight via elementor and it's working. I hope my translations won't get deleted again... Can this be guaranteed?

September 25, 2018 at 7:46 am #2762867

Bruno

My sincere apologies for the delay. Translations should not be overwritten, but I need to know how you are translating the content of your site.

From what I've noticed, you're using Translation Editor, but you're trying to translate the content of your site using the native interface of Elementor.

Also, now that I can access your site I see that some of your plugins are not updated as the Elementor and Elementor Pro.

The page is translated correctly. If the problem persists, try to update the Elementor plugins and test again.

If the problem still persists, please let me know exactly the steps you are taking to have the page overwritten with English content. That way, I can try to replicate the problem.

Thank you.

September 25, 2018 at 7:56 am #2762889

vanessaZ-2

Hi,

Thanks for your response. But I only had to edit the front page since it got deleted, for I don't know what reason.

Is there a way for you to fix and sync the plug ins? 🙁

- My other issue is this page: hidden link

- It is supposed to look like this: hidden link

I just continued using the steps, it only copies the text, but not the format and template.

Another issue that I have is this:

hidden link

It was successfully translated to German, but the formatting in font colour and text is very different. hidden link

Just these two pages. The rest have similar issues to the last one where the text is copied, but the format is not. How can this be fixed? Thank you.

September 26, 2018 at 7:59 am #2766296

Bruno

Hello,

When I try to access your site, the "Not available" error message appears. I'll attach an image for you to see. Please, could you check?

About your previous post, you're talking about the URL, correct? If so, the page currently being displayed as "?page_id =1234" may not be published.

Go to this page again (on the original language) and using the language selector at the top, switch to the secondary language. Make sure both pages (original and translated) are "Published".

When you created the page in the default language, did you change the color of the text? If yes, please, could you follow the same steps to change the color of the content in the secondary language? Perhaps this has simply not been synchronized and you need to edit the color in the secondary language as well.

Please, note that as I posted above, it is recommended that you use Translation Editor to do your translations. Using the Translation Editor, both problems should not happen.

To do this, just go to the default language page and click on the pencil icon in the "Language" metabox.

Thank you.

September 26, 2018 at 8:01 am #2766310

vanessaZ-2

Can we have a screenshare so I can show you the issues so that this ticket won't get any longer?

Thanks.

September 26, 2018 at 8:02 am #2766314

vanessaZ-2

I can access it properly with the credentials I gave you too. Even made some changes using the same account. Please let me know how we can have a call so I can show you the errors, because it really is an issue, and it is rendering very differently on your Translation Editor.

September 26, 2018 at 8:07 am #2766350

vanessaZ-2

Issue 1:

The text color is different from the english text colour.
- We edited the English text colour when we created the website, it's not default.
- When we try to load the DE page using elementor, the attached error appears (Console box).
Please advise what to do.

Let's still proceed with the screenshare for issue 2, it's something that can be shown in just screenshots. I am using the WPMLTranslate account to do all this so we should have the same access should you log in. Thank you.

September 26, 2018 at 11:55 am #2767032

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I am very sorry to say that Bruno has taken holiday so I will be helping you now. I´ll do my best to catch up with all that you and Bruno have already worked on.

I need to clarify that we do not offer any kind of screen-sharing support. All of our support is done asynchronsouly via the support forum.

I also have to inform you that I am not able to reach the login-page of your site. As Bruno said, when I try to access your site, the "Not available" error message appears.

This needs to be corrected before we can continue any type of troubleshooting.

I should also advise you that mixing the Translation Editor and the Elementor Editor is normally not advised. However, if you find that it is necessary to use the Elementor Editor directly because there are widgets that you are using and that are not supported by WPML, then I would highly recommend that you always create your tranlsations by first duplicating the translated post and then use the option to "translatie independently".

There are also some known WPML issues with the Elementor Editor and global widgets and templates. As a general rule, if you are using templates or globla widgets, these must be fully translated/duplciated to the target language before inserting them in translated posts/pages. If you don´t do this, the result can be an inablility to open the Elementor Editor in the 2nd language.

With these comments, I wait until you have sorted out the system access issue.

When you write back, please be very specific on what issues you have. Include the steps to recreate the problem and links to the specific pages. Use annotated screenshots to make your explanations as clear as possible.

Kind regards

September 26, 2018 at 12:01 pm #2767097

vanessaZ-2

Hello Yvette,

Thanks for responding. Understoond re: screenshare.

I don't think my issue here is being understood correctly though...

1. The log in has been sorted. Can you please try again? I've logged in using the same link, using the same account credentials since last Friday and it has been working fine.

2. The Translation Editor does not capture the format of the Elementor page. Some sections are displayed as 1 paragraph. The font formats are different. Even Bruno advised to use the Elementor Editor to fix the formatting issues in the translated page. You may view my former screenshot which shows that I cannot proceed with Elementor Editing due to some "uncaught error". I need this resolved.

3. There's also an instance when I added a translation following the tutorial Bruno provided. Suppose I have 10 sections in the English format, WPML only caught 3 boxes and lumped all content into 1 translation box. So when I finally saved the page, it didn't follow the Elementor format at all.

I hope these are already specific enough vs previous posts. It's a bit tiring doing a back and forth.

September 26, 2018 at 12:12 pm #2767138

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Please view this screencast to see what we are experiencing on our end. We cannot connect to your site:

hidden link

We also hate long tickets. They are messy and confusing - I see that there are links and exampels in previous messages so I will work off of those. Just write back when you are sure we can connect.

Thanks

September 26, 2018 at 12:16 pm #2767145

vanessaZ-2

Hi Yvette,

I am sure that you can connect.

I see that you tried to connect via Spinifexit.com/wp-admin.
It's part of my instructions to connect via SpinifexIT.com/noyoucant - our custom log in link...

You can see this instruction on the private form.

We have a secure log in link to avoid bots from attempting to log in...

September 26, 2018 at 1:00 pm #2767339

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

You custom login link is redirecting to wp-admin. Please watch the video:

hidden link

Just like Bruno told you before - we cannot connect.

September 26, 2018 at 1:15 pm #2767418

vanessaZ-2

It works fine with me.
Can you please try with a new browser? so the first entry of wp-admin is not used?
Type hidden link

Please see this video. I just logged in using the same link and account.
hidden link

September 27, 2018 at 6:02 am #2769377

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

That helped a lot!

I still cannot login with a normal Chrome session but it works with an icognito mode.

I can now work on this.

September 27, 2018 at 2:58 pm #2770959

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Sorry for the delay. Here are my observations I could make with the privileges that the userid had. Normally, we ask for full admin access so we can review all wordpress configuration options.

1. Templates and Global Widgets
These must be translated or duplciated to target languages if you want to use them in translated pages.

Right now, they only exist in one language.

2. ATE vs CTE
I see that you are currently using the "Classic Translation Editor". I have had tickets where Elementor global widgets were only translatable once they were duplciated/copied and only with the ATE.

So, once you have duplicated/translated your global widgets and templates to all languages and you still are not able to get the results you want using the Classic Translation Editor, please try changing to using the ATE.

You do this here: WPML -> Settings -> How to translate posts and pages -> Transaltion editor options

Thanks for letting me know the result of these steps.

The topic ‘[Closed] This tutorial is different from console’ is closed to new replies.