Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: The blog page title is set within the theme options. How can I translate that string? It appears in the breadcrumb in the original language.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/translating-theme-options/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by francoisP-2 3 years, 10 months ago.

Assigned support staff: Otto.

Author Posts
January 19, 2018 at 4:28 pm

francoisP-2

Hi,

Individual posts are OK, but the main posts page is not, title & breadcrumbs show in English, should be in French.

Blog page name (English): News (hidden link)

Blog page name (French): Nouvelles (hidden link)

See pictures.

Thanks!

Regards,

François

page-2.jpg
page-1.jpg
January 21, 2018 at 7:23 pm #1491213

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello François,

Please apologie for the delay in answering. This is not usual in this forum. I'll take care of your ticket and reply time will be shorter from now.

Can you please update WPML and its add-ons to their latest version and let me know if the issue persists after that? Please back up your site before updating.

If it does, it looks like a compatibility. So, before moving forward I suggest checking these alternatives:
hidden link
https://wpml.org/documentation/getting-started-guide/site-navigation/customizing-wpml-navigation/

Let me know if it helped, please.

Kind Regards,

Otto

January 21, 2018 at 7:43 pm #1491226

francoisP-2

Hi Otto,

The issue persists after the update.

This is a template from Template Monster and should be "WPML ready".

What's causing this?

Thanks.

Regards,

François

January 21, 2018 at 9:40 pm #1491292

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello François,

Thanks.

I am not sure, maybe a new compatibility issue. It needs further investigation.

Is it possible for you to share a copy of the last version of the theme, so I can try it locally and investigate further?

I'll set next reply as private, so you can share a download link safely.

Once the issue is solved I'll delete the files.

Kind Regards,

Otto

January 22, 2018 at 3:33 pm
January 22, 2018 at 6:50 pm #1492629

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Please apologize for the misunderstanding, but you provided the DB file and I need to test the theme.

The form asks you for the DB, I am truly sorry I didn't explain this before.

I am enabling a new private reply. Please, upload the theme files and paste in the body of the reply a link so I can download it and test it locally.

If you prefer, I can access your site and get it.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Kind Regards,

Otto

January 22, 2018 at 9:06 pm #1492816

francoisP-2

Please access the site to get it. I supplied all access info when I opened the ticket.

Thanks.

François

January 23, 2018 at 12:22 pm #1493746

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello François,

Thanks, I am sorry I missed that.

To solve the issue, please add the following to WPML -> Translation Management -> Custom XML Configuration:

<wpml-config>
  <admin-texts>
    <key name="theme52702">
      <key name="blog_text"/>
    </key>
  </admin-texts>
</wpml-config>

Then, go to WPML > String Translation and you will find the string "News" available to translate under the domain "admin_texts_theme52702"

Just translate it and it will show on the front end.

Let me know if this helps, please.

Kind Regards,

Otto

January 23, 2018 at 5:37 pm #1494325

francoisP-2

It works!

Thank you very much Otto!

Regards,

François