This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by pierS-2 1 month, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
September 7, 2019 at 9:58 am

pierS-2

Hi,

I have attached screenshot of the admin and frontend.

I can not find these strings for translation

I spent a while with theme developer and they told me to contact WPML, in order to fix it.

Please let me know

regards

September 8, 2019 at 10:46 am #4531155

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have logged in to your site and enabled Iconbox translation by selecting ‘text, title and description’ checkboxes from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> stm_theme_options >> header_builder > bottom and hit apply button.

Now strings are available for translation as you can see in the attached screenshot.

You can add translation from WPML >> String Translation.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

September 8, 2019 at 11:13 am #4531235

pierS-2

HI,

I have checked your admin strings but the frontend is still not translated

Please investigate a little more.

Kind regards

September 8, 2019 at 1:21 pm #4531633

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have fixed this issue by using our XML method and added the following XML code:

<wpml-config>
    <admin-texts>
        <key name="stm_theme_options">
            <key name="header_builder">
                <key name="bottom">
                    <key name="right">
                        <key name="*">
                            <key name="data">
                                <key name="text" />
                                <key name="description" /></key>
                        </key>
                    </key>
                    <key name="left">
                        <key name="*">
                            <key name="data">
                                <key name="title" />
                                <key name="description" /></key>
                        </key>
                    </key>
                    <key name="center">
                        <key name="*">
                            <key name="data">
                                <key name="title" />
                                <key name="description" /></key>
                        </key>
                    </key>
                </key>
            </key>
        </key>
    </admin-texts>
</wpml-config>

In WPML >> Settings >> Custom XML Configuration section and now string showing correct translation at frontend.

Thank you

September 8, 2019 at 1:46 pm #4531725

pierS-2

My issue is resolved now. Thank you!