This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Extra Product Options - Translated global form not applied to translated product Solution: ---------------- So in short: - Edit the Dutch Global form - Add the Dutch products in the Dutch Global form and save it - Edit the English translation of the Global form - Remove the Dutch Products - Add the English products (using their post ID) and save it - As soon as you save the form, the English products will be visually removed and the Dutch products will be there instead. Anyway, the English products will be correctly saved and you can now close the edit page. ---------------

It has been escalated already, however we can't do anything to fix it. This is a reply from the plugin author:

""""""""""""""""""""""""""""""""""""""""""""

The step you describe as " Assign this form to the WC product (Test EN)" is where the problem is.

Global forms cannot be assigned to individual products when using WPML.

""""""""""""""""""""""""""""""""""""""""""""

Another client said this as well: "I was in contact with the plugin support team and they told me that it doesnt work if its a global form, you will need to export these global forms and import them directly to your product page using the TM EXTRA OPTIONS -> CONSTRUCTOR FIELD, but it has to be in the original language, so this way you can edit the translated page later and again directly at the product page, there it will show the option to translate the forms."

Author Posts
March 31, 2019 at 10:39 pm

cyrilb-8

I am trying to:
correcty display website after updating your plugin
Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
english website should show english tm extra options
Instead, I got:
since i did an update of wpml plugin in all product the tm extra option is showing an other language that the current one:

English version of website, tm extra option show in german ect...

Thank you for your help

March 31, 2019 at 10:45 pm #3502703

cyrilb-8

image

April 1, 2019 at 9:45 am #3506001

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me where can I see the forms? Have you translated these forms so is the problem that strings aren't translated, or the forms that you selected for each of the product in the backend isn't the correct form - the form you actually chosen?

I also checked some of these strings within string translation, but none of these seem to be translated (strings such as Wähle dein Hotel aus)?

Regards,
Bruno Kos

April 1, 2019 at 2:36 pm #3509041

cyrilb-8

Hello Bruno,

thank you for your answer.
this is the live website hidden link

everything is working fine as soon as i update wpml its broke all tm extra option
on the live site there is no string translation for that but in they are in tm extra option
see picture

April 2, 2019 at 10:18 am #3515823

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I think I found the reason - it seems like that the same form is applied to the product and all translations. See this:
hidden link
hidden link

Even if we change this to Spanish translation product ID, it would not work - it saves the original post within this field, so it looks like a compatibility issue. It should save Cuatrimoto, Tirolesas y nado en Cenote here, however it always reverts it back.

Can you please check this?
https://wpml.org/forums/topic/tm-global-extra-product-options-translated-form-not-applied-to-translated-page/#post-2528719

And the whole thread? That seems to be the exact issue if I am not mistaken, can you confirm? There is also a suggested workaround for this.

It has been already escalate to our compatibility team with a status of "won't fix" and we even have a direct reply from developer:

Global forms cannot be assigned to individual products when using WPML.

Regards,
Bruno Kos

April 2, 2019 at 4:46 pm #3519191

cyrilb-8

Hello Bruno,

thank you for your reply.

Important note our website is working without any problem only when we update your plugin this problem show up
live site: hidden link
hidden link
see capture.

since almost a year now we cant do update of your plugin because this bug append, so why is the previous version working

in the global forms in the live site the configuration is exactly the same.

I did try on the live site to update spanish language and save it withe english product.
result form will be show in english
i try to revert it with spanish product number and it work back in spanish

i did the same on staging website but it would put me all form after in english, i try to empty mi cache but it doenst work, could you try on your end?

Thank you

April 3, 2019 at 7:38 am #3523135

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Based on https://wpml.org/forums/topic/tm-global-extra-product-options-translated-form-not-applied-to-translated-page/, that client also used 4.0.4. and the workaround worked for them. It is difficult to pinpoint what has changed since in both WPML and TM plugins that changed this behavior.

So the below workaround does not work any more?

----------------
So in short:
- Edit the Dutch Global form
- Add the Dutch products in the Dutch Global form and save it
- Edit the English translation of the Global form
- Remove the Dutch Products
- Add the English products (using their post ID) and save it
- As soon as you save the form, the English products will be visually removed and the Dutch products will be there instead. Anyway, the English products will be correctly saved and you can now close the edit page.
---------------

I could bring this to our Compatibility team. Can you tell me you would be interested in setting up this on our clean Sandbox install for further testing and debugging? We would only need 1 translated product with 1 form so that we can emulate the issue.

Let me know and I will set it all up for you.

Regards,
Bruno Kos

April 13, 2019 at 3:08 pm #3604915

cyrilb-8

hello Bruno,

no it doesnt worl when i use the workaround i got all form in English language

hidden link

yes please forward it to the compatibility team

thank you

April 15, 2019 at 7:46 am #3610637

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It has been escalated already, however we can't do anything to fix it. This is a reply from the plugin author:

""""""""""""""""""""""""""""""""""""""""""""

The step you describe as " Assign this form to the WC product (Test EN)" is where the problem is.

Global forms cannot be assigned to individual products when using WPML.

""""""""""""""""""""""""""""""""""""""""""""

And based on the further feedback from our compatibility team, there is nothing we (WPML) can do about this. 🙁

Regards,
Bruno Kos

May 4, 2019 at 9:49 pm #3740993

guilhermes-9

I was in contact with the plugin support team and they told me that it doesnt work if its a global form, you will need to export these global forms and import them directly to your product page using the TM EXTRA OPTIONS -> CONSTRUCTOR FIELD, but it has to be in the original language, so this way you can edit the translated page later and again directly at the product page, there it will show the option to translate the forms.