Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 3 voices.

Last updated by Andrés 4 years, 3 months ago.

Assigned support staff: Andrés.

Author Posts
October 6, 2017 at 7:51 am #1393246



After installing the plugin I get the following notification:

To easily translate Visual Composer, you need to add the following WPML components:

WPML Translation Management (Install | Download)
WPML String Translation (Install | Download)

When clicking the download links I'm just send to my plugins page.

Where do I find these WPML components? I checked my account, but I can't find them.


October 9, 2017 at 6:48 am #1394890


Hello Steven,

You have the Multilingual Blog license that doesn't include WPML String Translation and WPML Translation Management. This is why you can't find them.

If you want to install them, you'll need to upgrade your license to Multilingual CMS.

You may read about the differences between the Blog and CMS licenses at

WPML Translation Management adds the WPML's Translation Editor that makes translating pages created with page builders easier. You may check how it looks like at
WPML String Translation allows you to translate your theme and plugin strings in your admin panel, including the dynamic strings added as theme or plugin options.

However, you still can translate your pages created with Visual Composer without WPML String Translation or WPML Translation Management. In this case, you will be using the native WordPress editor.

October 10, 2017 at 7:50 am #1396266



I have upgraded the plugin and installed the add-ons.

I want to translate my pages using visual composer.
However, when I click the + button, the only fields I can translate are from the yoast seo plugin. The actual content fields are not listed.

I use the aloom theme.

Please advice.


October 10, 2017 at 9:27 am #1396408


Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello there,

As Joanna is not available I would like to take care of your case, if you agree.

I'm glad you upgraded your WPML licence. Now, could you please try this procedure:
-Go to Plugins -> Add new -> Commercial -> and click on "check for updates"
-Edit the translation and finish it as it is (mark it as complete).
-Make a small change in the original page
-Edit the translation again
Does it work this time?

Best regards,

October 10, 2017 at 10:08 am #1396478


It worked for one page, but not for other pages.

October 10, 2017 at 11:38 am #1396601


Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Could you repeat the previous procedure after performing the following actions? This will guarantee that your installation is ready for translation:

1. Could you please upgrade your WordPress version?

2. Could you please upgrade your WPBakery Visual Composer to +5.3?
hidden link

3. Could you please increase your memory RAM? Particularly, your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:
- MemoryLimit 256M
- WP Memory Limit 40M

Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.