This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.25 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 3 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
September 18, 2018 at 7:39 am

pabloD-15

Hi,

I have the Goodlayers Ininite there and I use the Page Builder
When translating a very simple page (e.g. hidden link) with the Standard Translation Editor, I see hundreds, if not thousands, of fields to translate (see screenshot)- most of which are items not visible which do not need a translation (e.g. wrapper, background, boxed, 0px, 3px, center, pattern-6,.......).

Is there a way to show only the fields which really need a translation, and not all the "back-end" fields of the page builder?

thanks!
Pablo

September 19, 2018 at 2:28 am #2746935

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Make a full backup of the site for security reasons.
- Go to WPML -> Settings -> Custom Fields Translation -> Unlock 'gdlr-core-page-builder' and 'gdlr-core-page-option' -> Set this custom fields to 'Copy' -> Save the changes.
- Edit the page in the original language -> Make a small change -> Save the change.

Could you tell me if the issue persists?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 19, 2018 at 3:27 am #2747197

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

This seems to be happening because your theme set up for this to be translatable. On the Appearance > Editor > wpml-config.xml file, there are these lines:

    <custom-fields>
        <custom-field action="translate">gdlr-core-page-builder</custom-field>
        <custom-field action="translate">gdlr-core-page-option</custom-field>
    </custom-fields>

I believe the "gdlr-core-page-option" option is just the option that is creating all the fields you are looking at. You could change this, but I'm not sure if this should affect any of your theme's option. You should contact the authors of the theme to check this out.

If you want to change this, follow the steps below:

- Click on the WPML > Settings > Custom XML Configuration
- Insert these lines:

<wpml-config>
    <custom-fields>
        <custom-field action="copy">gdlr-core-page-option</custom-field>
    </custom-fields>
</wpml-config>

- Click on the Save button

This should make the options to be copied instead of translated.

I should recommend, however, that you connect the author of your theme to see why he is using the "translate" option rather than "copy".

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

October 1, 2018 at 9:11 am #2777524

pabloD-15

Hi!

sorry for the delay - I was OOTO for one week.

So, I tried both options, unfortunately now the result is the opposite! No fields to translate...
The only field to translate I can see now are the Title of the page, and the Word Press Editor Content.
Thus I cannot see the value fields which I created with the theme page builder

Taking as an example this page (hidden link), in my original situation I see hundreds of fields to translate, which all start with field-gdlr-core-page-builder

However the only 2 I should translate are:
field-gdlr-core-page-builder-0-0-items-0-items-0-value-title
field-gdlr-core-page-builder-0-0-items-0-items-2-value-content

If I apply your suggestions, the result is that the only field to translate I see are the Title of the page, and the Word Press

Is there any other way to only show those 2 fields?
It's strange because the Infinite Goodlayer theme should be compatible with WPML (was one of the supported themes)

Thanks,
Pablo

October 2, 2018 at 7:56 am #2780588

pabloD-15

Hi!

sorry for the delay - I was OOTO for one week.

So, I tried both options, unfortunately now the result is the opposite! No fields to translate...
The only field to translate I can see now are the Title of the page, and the Word Press Editor Content.
Thus I cannot see the value fields which I created with the theme page builder

Taking as an example this page (hidden link), in my original situation I see hundreds of fields to translate, which all start with field-gdlr-core-page-builder

However the only 2 I should translate are:
field-gdlr-core-page-builder-0-0-items-0-items-0-value-title
field-gdlr-core-page-builder-0-0-items-0-items-2-value-content

If I apply your suggestions, the result is that the only field to translate I see are the Title of the page, and the Word Press

Is there any other way to only show those 2 fields?
It's strange because the Infinite Goodlayer theme should be compatible with WPML (was one of the supported themes)

Thanks,
Pablo

October 2, 2018 at 10:59 pm #2782939

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Pablo,

In this case, unfortunately, it is not possible to copy all the fields except the ones you want. This is because all fields are within the same "gdlr-core-page-builder" option.

In this case, the "gdlr-core-page-builder" option should be marked as "Translate" and you should copy all fields that you do not want to translate.

Within the Translation Editor, there is a "Copy all fields from original" button that makes all fields to be copied at once. Then you can translate the fields you want.

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.