Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Robert 7 years ago.

Assigned support staff: Robert.

Author Posts
November 4, 2014 at 11:15 pm #505754

ferjoltO

I am trying to:I have a WP site for a News Agency that is build in 3 different languages via WPML. The webmaster before me had installed the 2.9 version of sitepress and, since he is not working anymore with us, i was obligated to create a new account with you and purchase it again to update it. The problem is that, the site, after WP update from 3.9 to 4.0 is overloading the CPU of server (dedicated server with 16gb of ram and Intel(R) Xeon(R) CPU E5620 @ 2.40GHz). Also, every 10-15 minutes the sites appears to have mysql connection problems. the cpu loading goes up to 750%. I have seen via Query Debuger that my site is making about 800 queries, while 486 of them are from sitepress-multilingual-cms and 270 from theme (that claims to be WPML ready).
I have tried with sitepress-multilingual-cms deactivated and the total queries are 285-290 queries and does not appear any mysql connection problem or overloading problems.
Would you, please, help me with this issue? It's a very important website and we cannot allow to have so many downtimes or a site that doesn't work as it should.
Thank you and hope that you can help us.

P.S. All plugins are up to date. Also the Theme. We are using wp super cache too.

query-debuger.jpg
November 5, 2014 at 12:21 am #505769

ferjoltO

This are 3 printscreens from P3 Plugin Profiler.
Thank you!

p3-3.jpg
p3-2.jpg
p3-1.jpg
November 5, 2014 at 12:24 am #505775

ferjoltO

This is a printscreen of the same plugin with WPML plugin deactivated.
Thank you!

p3-wo-wpml.jpg
November 5, 2014 at 11:01 am #506029

Robert

Hey Ferjolt,

Using any multilingual plugin will escalate the number of queries for connecting and finding language information.

There are a few settings that help increase the load time such as disabling the setting called Adjust IDs for multilingual functionality, under WPML->Languages.

Please read through and reference these links:
+ http://wpml.org/2012/01/can-your-site-run-faster/
+ http://wpml.org/faq/how-to-optimize-mysql-queries/
+ http://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/

Thanks,
Robert

November 5, 2014 at 11:25 am #506050

ferjoltO

Hello,
Your reply is pretty standard and is not a really help. Before i opened this thread, i checked everything in here and in Google. Anyway, I have checked all three links before and everything is just those links recommends. I have Cloudflare, Wp-Supercache, Minify js, css, html. All settings are as you suggest.
I understand that the WPML normally increase the db queries but i don't see why the increase is more than 60%.

November 5, 2014 at 12:01 pm #506087

Robert

Hey Ferjolt,

Sorry if the suggested articles didn't provide further help but of course we need to address the standard changes first. I will now escalate the issue to our 2nd tier support in order to debug the issue further. I will get back to you as soon as possible.

And the issue only became apparent after the latest update?

Could you please provide your debug information? You can find this information in WPML > Support > Debug. You can paste your debug information in the debug field below.

Thanks,
Robert

November 5, 2014 at 12:07 pm #506092

Robert

Also, would it be possible for you to duplicate the site in a testing environment for us to access and debug on? If so, please provide your WP admin and FTP credentials in the private response field below, I'll take a closer look at your settings and debug the issue. NOTE: Please make a fullback up of the site.

Thanks,
Robert

November 5, 2014 at 4:00 pm #506317

ferjoltO

Sent...and waiting for good news 😉
Thank you!

November 6, 2014 at 8:58 am #506670

Robert

The post page should be debugged first to insure WPML is working properly, may I use a duplication plugin to clone your site for our review?

Can you please confirm for me that you have a may a full backup?

Thanks,
Robert

November 6, 2014 at 10:51 am #506807

Robert

Can you also verify for me that the mbstring PHP module is installed on the server?

November 6, 2014 at 12:22 pm #506905

ferjoltO

Hello Robert,
Firstly, mbstring is installed and working:

 Package php-mbstring-5.3.3-40.el6_6.x86_64 already installed and latest version 

Secondly, you can do whatever you have to do, but be careful with personal data, please. Also, the whole site has about 100GB for the moment 😉
Thank you!

November 7, 2014 at 10:59 am #507543

Robert

Hey Ferjolt,

Could you please upgrade your PHP version? WPML v3.1.8.2 has some issues with PHP <5.4 so updating PHP may help a little in this. Let me know the result.

Thanks,
Robert

November 7, 2014 at 1:47 pm #507697

ferjoltO

Hello Robert,
PHP 5.4.16 is installed but i don't see any changes on anything. I need help as soon as you can on this issue, please.
Thank you!

November 7, 2014 at 2:21 pm #507723

Robert

I am working with the 2nd tier support team on the issue and we are addressing the problem as quick as we can. Please stand by for further information.

Thanks,
Robert

November 7, 2014 at 2:28 pm #507730

ferjoltO

I was obligated to disable the WPML plugin since our article writters was unable to add any new post or edit any exisiting one. Now, when i activated it again i got:

AJAX Error: Internal Server Error [500]
URL:hidden link

The topic ‘[Closed] Too many queries with wpml active’ is closed to new replies.