Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Shekhar Bhandari 3 years ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 24, 2017 at 12:05 pm #1409975

massimoS-6

I am trying to: set WPML for a customer

Link to a page where the issue can be seen: hidden link (it cannot be seen right now because otherwise my customer would have his site blocked)

I expected to see: a normal WPML installation

Instead, I got: Every time I turn the plugin on, I get the too many redirects page (not related to a particular language).
What I have already tried: leaving only WPML pugins on and also switching to a standard theme. Nothing changes, I still have the too many redirects error.

October 25, 2017 at 7:53 am #1410896

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @massimos-6,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please let me know the following for tracking the issue.

1) Which option you have selected for *Language URL format* of WPML>>Languages?

2) Which option you have selected for *Browser language redirect* of WPML>>Languages?

3) Please use different options for *Language URL format* of WPML>>Languages and check you are getting the same result or not. For an example *Language name added as a parameter*.

4) Are you using any redirection logic in *.htaccess* file?

4) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

October 27, 2017 at 4:43 pm #1414341

massimoS-6

Sorry for the late reply Bigul,

I can see that my client set some redirection logic, should I paste the .htaccess code here?
Points 1,2 and 3 have been verified already and nothing changed. I tried different URL formats and automatic language switching is not active.
I set the debugger on and here is the pastebin link https://pastebin.com/hqYmP1FV

Thank you,
Max

October 27, 2017 at 7:43 pm #1414518

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @massimos-6,

Thank you for the details. Please share with me the redirection logic using in *.htaccess* file for more details. You can share it as a http://pastebin.com/index.php link.

--
Thanks!

Bigul

October 28, 2017 at 6:46 am #1414626

massimoS-6

hello Bigul,

here is the link: https://pastebin.com/7fUD7mr7

October 30, 2017 at 2:09 pm #1415750

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @massimos-6,

Thank you for the details. In the first look the *.htacess* code looks okay, but I have two more requests to track the issue. Please do the following steps after a full site backup and let me know your feedback.

1) Rename the current *.htaccess* file. Visit Settings>>Permalinks and update the permalink settings(just resave). Then make sure you are still having the issues.

2) Maybe you are facing this issue because of compatibility issues. So to make sure if possible, please do the following steps.

a) Switch for a moment to a WordPress default theme like 2017. Becuase you are using an older version of the *RealHomes* theme(1.7) and it is a compatible theme with WPML. The current version of the theme is 3.3.1. Please check the following links for more details.

https://wpml.org/theme/realhomes-theme/

hidden link (Recent Updates section)

b) Deactivate all the plugins that are not related to WPML
c) If the issue is gone, activate one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

October 30, 2017 at 2:42 pm #1415795

massimoS-6

Hi Bigul,

I will try what you said at point 1.
Everything in point 2 has already been done and it did not work.

Cheers,
Max

October 30, 2017 at 4:56 pm #1415995

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Max,

Thank you for the updates. Please check the *Point 1* and let me know your feedback.

If you are still having the issues, I would like to access admin area of your site for further checking. Please fill the private details fields after a full site backup. Check the following links for more details about our private information sharing.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

November 2, 2017 at 6:08 pm #1419448

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Max,

Thank you for the login information. I made a duplicator copy of your site now.

I have one more request. We have a released a new version of the WPML(3.8.4) yesterday. If possible please upgrade to the latest version of the plugin after a full site backup. Then make sure you are still having the issues or not.

--
Thanks!

Bigul

November 13, 2017 at 1:30 pm #1428975

massimoS-6

Sorry for the late reply Bigul, the customer replies once in a fullmoon!
they still have 3.8.3 but I cannot see any update notice from their site??

November 14, 2017 at 5:28 am #1429639

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello @massimos-6,

Bigul is on vacations, so I am taking care of this ticket, hope that is ok. 🙂

Could you please ask him to manually install the plugin and let me know if this helps.

★ INSTRUCTIONS: ★

❌ Backup your website and database ❌
• Deactivate/Delete the “Installer” plugin (if you have it)
• Deactivate all WPML plugins
• Login via FTP to your wp-content/plugins folder
• Delete all WPML folders
• Go to http://wpml.org/my-account/downloads/ and download the latest stable WPML Multilingual CMS Plugin, then extract it.
• Upload the plugin via FTP to the wp-content/plugins folder.
⌥ alternatively you could upload the .zip file using Dashboard > Plugins > New > Upload
• Activate the WPML plugin via WP Dashboard > Plugins
• Complete the setup, if needed
• Register WPML for your site (at the end of setup, clic on “generate key” button)
• Navigate to Dashboard > Plugins and locate WPML Multilingual CMS
• Clic on the blue link that says “Registered”
• Download and activate all needed WPML AddOn Plugins

This should not generate any problems.

⌥ In case you want to register WPML for your site manually please make sure to enter the naked URL of your site in wpml.org (something like hidden link)

⌥ In the extreme case, please try to register with all non-WPML Plugins deactivated,
and Theme Twenty sixteen enabled.

Look forward to your reply.

Thanks

The topic ‘[Closed] Too many redirects message’ is closed to new replies.