Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I have first created a "Person" (CPT by Toolset) in Dutch and checked a Role for this person. I have then duplicated this post into French and English, but the checkboxes are empty there.

Solution: Update WPML to versions greater than 3.6.2

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Otto 4 years, 7 months ago.

Assigned support staff: Otto.

Author Posts
October 24, 2016 at 2:37 pm #1121806

Kristof

I am trying to: duplicate a post to another language
I expected to see: the Role checkboxes to be checked like in the original language
Instead, I got: empty checkboxes

Steps to duplicate the issue: I have first created a "Person" (CPT by Toolset) in Dutch and checked a Role for this person. I have then duplicated this post into French and English, but the checkboxes are empty there.

Edit Person ‹ Itinera Institute — WordPress.jpeg
October 24, 2016 at 3:11 pm #1121829

Kristof

It seems that post was no longer a duplicate, but got translated individually, however, the lock is still on the Role checkboxes, so we cannot select this Role for the translated post.

October 24, 2016 at 7:14 pm #1121997

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

Can you please go to WPML > Translation Management > Multilingual content setup > Custom fields and check if those fields are set to "Translate". If not please set them to translate and check if the issue persists.

If this does not help, can you please export your Types configuration and share it with me? This way, I will be able to reproduce the issue locally and it will be better to debug.

To export your CPTs go to Toolset > Export / Import.

I will set next reply as private so you will be sharing it just with me.

Let me know your results, please.

Kind Regards,

Otto

October 25, 2016 at 6:36 pm #1122970

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you.

Yes, it should work that way.

The import is not working 🙁

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Kind Regards,

Otto

October 26, 2016 at 2:26 pm #1123673

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you! I managed to deploy your site locally.

But I couldn't reproduce the issue. Maybe I'm missing something.

This is what I've done:
-Created a new persona (Dutch)
-Assigned the role "General Director"
-Duplicate the "persona" to English
-The English persona has the same role assigned and it's locked (as expected)
-Click on translate independently => no changes

Do you have different results? Did I miss any step?

Kind Regards,

Otto

October 26, 2016 at 2:58 pm #1123714

Kristof

Hi Otto,

I cannot quite remember how we created the translations for the Persons 🙁 I guess for some we checked the Duplicate boxes, but for some we clicked the Translate + sign. When we create a duplicate via the checkboxes, the Role is copied. When we create a translation via the + sign, the Role is NOT copied to the translation, nor can you edit the checkbox as it is locked. We can Overwrite with Dutch content, but loose our translations.

But how can we correct this for existing Authors where the translated Role is not checked (without losing our translations)? For example Person "Bilal Benyaich" in Dutch and English is set as "Senior Fellow" but in French the Role is not checked. But the group of Checkboxes is locked.

Also for our Custom Post Type "Articles" we have a Post Field "Author" which should be the same for all translations of a specific Article. For most translations, the Author is not checked in the translation.

October 26, 2016 at 5:10 pm #1123851

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

You can set the field to "translate" in WPML > Translation Management > Multilingual content setup > wpcf-role and then you will be able to edit it in the translation.

Is this a suitable workaround for now?

Kind Regards,

Otto

October 28, 2016 at 9:43 am #1125091

Kristof

Actually, for the authors than can be a workaround, even though there are 80 persons, we can manually check each person post to see if their role is set correctly. However, there are about 3000 posts, we cannot begin to check each of them to see if the author is set correctly 🙁

When a CPT is set to "Copy into the translation", is should be linked/updated with the original language, even though the post might be translated independently, otherwise we would just mark is as Translate.

October 31, 2016 at 1:07 pm #1126489

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Yes, you are right. That's the expected behavior. And the workaround can be too much work 🙁

I'm checking the issue with our second tier supporters. I will get back to you as soon as I have news regarding this issue.

Thanks for your patience and cooperation to fix this problem.

Kind Regards,

Otto

October 31, 2016 at 5:54 pm #1126774

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Just an update.

I escalated the ticket to our second tier support. They will investigate further and get back to you as soon as they have an answer.

Kind Regards,

Otto

November 1, 2016 at 1:24 pm #1127305

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Just an update on the issue.

We confirmed the bug and the issue was passed to our DEV Team. They will find a fix and it will be included in future versions. Though I can't tell you which one for now.

If there is a workaround available before, I will let you know.

Thanks for your patience and understanding.

Kind Regards,

Otto

November 30, 2016 at 8:22 pm #1148132

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Can you please update WPML and it's add-ons to their latest version and let me know if the issue persists after that? Please backup your site before updating.

Let me know your results, please.

Kind Regards,

Otto

December 1, 2016 at 8:14 am #1148460

Kristof

Hi,
I have updated WPML and it's add-ons, but the issue still exists.
I start with a Person CPT in Dutch, where I have extra radio buttons, checkboxes and input fields. All are set to "Copy from original" in the Toolset plugin. Only the checkbox "Role" does not copy its setting from the Dutch language to English.

Do I need to set "Copy from original" a second time in the WPML plugin? Because even in WPML Translation Management wpcf-role is set to "Copy from original to translation".

Even when I do a new "Copy content from Dutch", the checkbox is not checked.

December 1, 2016 at 11:54 am #1148748

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you.

I updated our Dev Team with your results. I'll get back to you as soon as I have news regarding this issue.

Kind Regards,

Otto

December 12, 2016 at 5:35 pm #1158114

Kristof

Any update on this issue? We also have this Custom Post Type "Books" with a custom field "Author" which is set to copy from translation. However, the value in English is different from the value in the original language Dutch.