This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Radu 8 months ago.

Assigned support staff: Radu.

Author Posts
February 4, 2019 at 1:30 pm

Krzysztof

The custom fields created with the toolset display on the default language but not in the two other custom ones.

February 5, 2019 at 11:30 am #3161506

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Before we have a closer look at this, let's check a few things in order to make sure that everything is set up fine.

  • go to Dashboard → WPML → Settings → Custom Fields Translation;
  • make sure that the custom fields that you want to be able to translate are set to Translate (the last column);
  • go back to a page where you have this issue;
  • edit one of the translations;
  • make sure that all the fields from the Custom Fields section are translated and that the Translation is complete checkboxes are checked.

Can you check this out and make sure that everything's fine on this side, please? I'm asking for this because I added a new custom field on my site, followed all those steps and everything works fine on all the languages. I'm waiting for your message back.

February 5, 2019 at 11:42 am #3161601

Krzysztof

It is still the case, they are set correctly as far as i'm concerned. The whole Post Field Group is not beeing displayed on the custom languages.

CPT - "beers"
Post Field Group - "Product details"

THX for any help!

February 5, 2019 at 1:31 pm #3162154

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you give me access to the dashboard of the website where you have this issue, please? I know that you send me the duplicator but this might get fixed easier, without being needed to create a copy of your website.

Thanks,
Radu

February 5, 2019 at 2:05 pm
February 6, 2019 at 11:41 am #3165298

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I checked all the settings and everything looks fine. It seems that the custom fields are not appearing even when trying to change to the advanced editor either.

Now, I can see that you have a caching system on your website. In order to make sure that this is not causing the problem with the custom fields, can you deactivate it for a while, please? Also, you can go to Dashboard → WPML → Support area, click the troubleshooting link and use the Synchronize posts taxonomies and Clear the cache in WPML options. These two might do the trick.

Before doing any of these changes, please make a backup of your website. Nothing should go wrong but it's better to have a backup before doing any change.

February 6, 2019 at 3:55 pm #3166432

Krzysztof

Hi Radu,

i did evth. as requested, the problem persists 🙁 any other ideas?

thx!

February 7, 2019 at 1:36 pm #3170471

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I just tried to add a new custom field (just for a test) and it can be translated very well. You can check it out.

Also, I can see that some the description and the type can be translated. Regarding the Alkoholgehalt and IBU fields, these are set to be copied to the translation (in Dashboard → WPML → Settings area). The last two fields (Zutaten and Speiseempfehlung) will be available on the translation page right after you add some content to them. Basically, the fields that have some content on them will appear when translating the post.

Can you try to add some content to the last two fields that I mentioned and tell me if you can translate them, please?

February 11, 2019 at 1:07 pm #3182979

Krzysztof

Hi Radu,

i dont quite understand your instructions. Please try to add a new "beer" in the EN version and you will see that the "product details field group" is still missing. In the DE version evth. is ok

February 12, 2019 at 8:14 am #3187048

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I just created a new "beer" on your website (on the default language - DE) and added some content to all the fields. When I try to make a translation, everything comes up fine. All the fields appear except description (because it's set not to be translatable in Dashboard → WPML → Settings → Custom Fields Translation. Can you check this new item, please?

February 12, 2019 at 10:57 am #3187955

Krzysztof

Ok i updated the plugin and now the settings get updated. (It wasnt the case with the previous version) I still have the problem with the "wpcf-productdescription" it's set to "translate" but doesnt display in the translation interface. Any ideas why?

February 13, 2019 at 8:46 am #3192572

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Once you changed the description to be translatable, there are a few more things you need to do. First of all, you need to edit the New beer and check all the Translation is complete boxes. After that, hit the Save & Close button, go back to the original post, make a change to the description field (add an empty space at the end or a comma) and hit the Update button. Now, when you'll try again to translate the post, the new field will be shown. I updated the test beer so you can just simply go to the translation page and see that the description field is available now.

You might ask why is all this needed. Well, when a change is made a custom field and it's set to be translatable, nothing changes to the existing content. If you add a new beer, you'll see the description field available for translation from the beginning. However, for existing items, the check of all the custom fields is triggered only when the translation is complete and when a change to the original language is done. All these conditions need to be met because this "look for changes" check is consuming resources and you don't want to have a new check every time even the smallest change is made to your website. I hope that this little explanations makes sense.

February 13, 2019 at 2:27 pm #3194623

Krzysztof

Hi Radu,

nice that works just fine!

How about the wordpress editor? when dont use the WPML translate editor (screenshot) the "product description" - group does not display. Any idea why?

thx!

February 14, 2019 at 12:30 pm #3199620

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Is there any specific Beer I can check to see this problem (maybe the one that you used to take the screenshot) or can I create a new one so I can check things out? I'm asking this because this might be your live website and I'm trying to avoid adding new content for testing (better use what we have so far when possible).

February 14, 2019 at 12:42 pm #3199705

Krzysztof

Hi Radu,

thx! try any of the products the problem occurs everywhere

The topic ‘[Closed] Toolset Fields not displaying in translations after update to WP 5.0’ is closed to new replies.