This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Shekhar Bhandari 9 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
January 9, 2019 at 8:15 pm #3073639

Marina Joseph

I'm translating a CPT using custom fields through toolset types. I have about 15 fields that are all showing up in the translator. One fields has stopped displaying in the translator. It does still show in the default language post, just not the translated post.

The strange thing is that there is data showing up on the front end from when I entered information the field on some posts before it went away.

I added a few new test fields to see if they would show up, but they don't either. So no new fields are showing up. There must be something strange going on with the db.

Not sure if this is related, but when I make a change to the default language post, the pencil indicator for the translated page doesn't always go back to the circle saying that there is a change.

January 10, 2019 at 4:49 am #3074606

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

It seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup

If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

The topic ‘[Closed] toolset fields not showing in translator’ is closed to new replies.