This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
May 8, 2018 at 9:25 am #2026393

mikeH-19

Tell us what you are trying to do? Home page from English to French. I have done all the translation and this shows in the Translation Page. But when going to the French version it shows English.

Does this actually work??

See screenshot of Translation page. Go to home page and click French and still get English.

THIS IS URGENT AS I HAVE TO SHOW CUSTOMER SOLUTION ON FRIDAY.

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site? hidden link

May 9, 2018 at 5:08 am #2042988

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please check the attached images. French homepage is showing the translations for me. So please clear all types of caches and try it once again. If you are still having the issues, let me know the steps to replicate the issue on your site.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

May 9, 2018 at 7:21 am #2044475

mikeH-19

I have done this and I still cannot see French only English in both versions. I don't know how you are seeing French.

May 9, 2018 at 4:13 pm #2057632

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. It looks like the issue is happening when the *Language URL format* is *Language name added as a parameter*.

Please try the following steps after a backup and check the issue is existing or not.

1) Visit WPML>>Laguages
2) Scroll down to *Language URL format* section
3) Choose *Different languages in directories* option and save the changes
4) Go to WPML>>Support page
5) Click on Troubleshooting link (blue link in the middle of the page)
6) In Troubleshooting page, please click on the *Clear the cache in WPML* option

--
Thanks!

Bigul

May 10, 2018 at 6:27 am #2065486

mikeH-19

I have done all that and cleared the laptop's cache - problem persists.

May 10, 2018 at 2:43 pm #2074832

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. It may be happening because of compatibility issues. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate one by one to see with which one there is an interaction issue

If you are still having the issues, please fill the private details fields after a full site backup. I would like to access admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

The topic ‘[Closed] Toolset shows English and French but webpage only displays English’ is closed to new replies.