This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.93 hours from now. Thank you for your understanding.

This topic contains 69 replies, has 2 voices.

Last updated by Jamal 8 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
January 16, 2019 at 8:06 am #3096370

andiB-5

What are you trying to translate?

hidden link = Original Page
hidden link = Page after automatic translation to Korean - design complete lost!
hidden link - Page in Thai which has not even been translated until now!!! we worked ONLY on Korean Translation
even worse as the DIVI page contains GLOBAL elements like all below the Three Boxes JOIN US - OUR MEMBERSHIP , DONATE .... etc. are GLOBAL elements which appear on more than this or even on all pages also those pages got crashed completely in the look!

What are you seeing? (please include a screenshot)

Original Look and Feel compare with below than you see the huge problem!
1a) hidden link

1b) hidden link

1c) hidden link

please check the Live site!

crashed Look from WPML translation
1aWPML) hidden link

1bWPML) hidden link

1cWPML) hidden link
etc.

What's missing or not working for you?

I guess you can see that by your self WPML is crashing the complete site!
We tested it out on one page and assigned for one Page the Korean and Thai translation to the Translator and he Translated ONLY The Korean Language with automatic Translation and the result are changes even on Thai Translation and many other subpages with complete design Loss. The changes of Global Elements would be more than OK if they would keep the DIVI design but that is absolutely not the case. I would say DIVI and WPML won't work in their newest versions and WPML is not ready for DIVI content.

Total Crab
Kind regards
Andi

January 16, 2019 at 8:14 am #3096389

andiB-5

What is that "Chat"??? Looks like a Joke - of course we have here a huge problem because of that as we recommended to use WPML as it was written on your page and Forum that it is 100% compatible, which is definitely NOT the case as you can see.
How can we get back the former LOOK??? like you see it on the original page. Please respond fast as the customer is not at all happy about that and to see his crashed site after the translation!
If no chat - how long do we need for an answer?

January 16, 2019 at 8:25 am #3096403

andiB-5

Hi - it comes even worse - we just realized that even we did save ONLY in Draft all translations one by one as there is no way to save a whole page at one time with one click, all the changes are now even visible in PUBLISHED MODE on the live site!!!
hidden link

January 16, 2019 at 9:46 am #3096767

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Can you please paste your WPML Debug information in the Debug information field?
- http://wpml.org/faq/provide-debug-information-faster-support/

To make this a little faster, i would like to access temporarily your backend. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Best regards,
Jamal
WPML Support

January 16, 2019 at 10:14 am #3096954

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Thank you for your feedback.

Can i ask when did you update to WP 5.0.3?
I reenabled the private area and i will wait for your reply.

Best regards,
Jamal
WPML Support

January 16, 2019 at 10:50 am #3097175

andiB-5

Hi Jamal

The private message is not active

January 16, 2019 at 10:54 am #3097187

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Would you also answer my question about when WordPress update was done?

January 16, 2019 at 11:29 am #3097343

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for the access you have provided. I logged into your website and i have detect so many issues in the WPML->Support->Troubleshooting page.

But the only issue i can see about what you reported is the footer issue. It has lost all design in the translated pages. I am not sure what caused this ? the WPML update, the Divi update ?
But what i can tell right now, is that the footer is not translated at all.
Please follow our article on how to translate Divi global modules
https://wpml.org/documentation/theme-compatibility/divi-builder/#translating-divi-global-items

Let me know if this helps recover the footer issue ?

As per our support rules we are able to handle only one issue at the time. This help us to bring you a better service and also help other users to find all the information here exposed. For that reason I have to kindly ask you to open a new thread if you need further assistance, you can assign it directly to me. In that way you don't have to wait and we can continue working on it.

Best regards,
Jamal
WPML Support

January 16, 2019 at 12:03 pm #3097567

andiB-5

Hi Jamal

You can see the issue that complete CSS blocks seem to be displaced as the images show
What has to be with neutral background is suddenly green - just an example

So all those values are gone.

For example that is complete mixed up hidden link
I marked the white text - otherwise you can't see the actual problem
That green area went down to the next area which is actually a white area but now it is green - and honestly I have no idea why

"Transforming Healthcare Through Lifestyle Medicine"

is now
"Real Health Care Reform"

Why is it not translating what is on the page but what was there previously - longer time ago!

compare the area colors like they are in the original
here the Korean site
hidden link

In the Korean site are a lot of spelling errors as I can't read Korean at all, so somebody who can read has to do that but before that system has to work without problems.

I hope you continue working on it Thanks

- - -

This is the Translation Manager
hidden link

already that Visual View isn't correct actually in Translation Manager
hidden link

For me it looks like the translation get not even shown, so what get's done in the backend does not get displayed at all in the Frontend. - This could be caused by rewriting - I checked already .htaccess which is OK!

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

All your tutorials are actually not up to date with the new Frontend Only DIVI Builder since 5.0

Another Major Problem is that when choosing Korean Language suddenly all fields get translated to Korean too which makes it nearly impossible for developers to find their way, why don't you continue displaying the English Feld names when the language of the editor or translator is actually English. It is very hard to solve problems with translators when they suddenly read the Korean Language and you as the webmaster have to find out what that probably is in English and they don't see the English Names which we can't even read or pronounce those Korean signs.

hidden link

January 16, 2019 at 12:08 pm #3097628

andiB-5

Oh I just realize something which might help us to get a solution

When Frontend editing is ACTIVE the display of all fields is correct
hidden link

compare that with the previous one from Korean language when the Frontend Editor was not active. Now suddenly the White title is on Green ground and below it is a white Background.

Still it is mysterious why it shows not the same title actually but instead a former one "Real Health Care"

also the Footer has suddenly its design back
hidden link

I will check that also on the life site as that is really strange as it means that this design information is still available but WPML is not using it.

January 16, 2019 at 12:24 pm #3097683

andiB-5

I checked again the settings of WPML

hidden link

this looks OK

But strange thing is that on the live site it says "It looks like languages per directories will not function."
hidden link

even .xyz is a direct copy of .asia!

.XYZ
hidden link

.ASIA
hidden link

Its identical!

php.ini is identical same wpconfig.php

January 16, 2019 at 1:28 pm #3097914

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

Thank you for your feedback. We should definitely edit our docs regarding Divi update you mentioned.
The fact you mentioned in this picture may also need some attention.
hidden link

About this live site issue, can you click on details to check the error ? Can we check the return of the Ajax call ? If possible can we activate PHP debugging and see what will be written in the debug.log file.
hidden link

What about design in the live site, were you able to update it, or you are waiting for the "Different languages in directories" option to be set ?

Please let me know your finding.

Best regards,
Jamal
WPML Support

January 16, 2019 at 1:37 pm #3097964

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I forgot to mention that this issue may be caused by a caching or security plugin.
Can you check that too ?

Best regards,
Jamal
WPML Support

January 16, 2019 at 4:29 pm #3098486

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. The logs you provided has no reference to any file from our plugins or in sql queries.

So i will come back to the footer issue and i will suggest to follow our article. You can switch to the classic divi builder, see the attached image. You will need to create translations for the global Divi module.
https://wpml.org/documentation/theme-compatibility/divi-builder/#translating-divi-global-items

For the other issue of the header, i don't know what page is it. I will kindly ask you, to focus our work on footer in this ticket.
Provide more details about what pages are causing the header issue shown here
hidden link
And we can create another ticket for it.

Best regards,
Jamal
WPML Support

January 17, 2019 at 12:49 am #3099927

andiB-5

Hi Jamal

it is exactly the same page - just the top of it - with the header issue - and you always should work top to bottom to solve problems.

I suggest we first need to get the translation showing at all!
The footer elements have already been translated - you can check it in the backend!

It is always the same page - hidden link
as long as we can't get even that simple page translated it does not make any sense to translate all others.

hidden link
you can see the URL in the URL bar

and you can read the title in the ORIGINAL English page

when we translate it shows suddenly the following You can see the difference in the URL - now with /ko/ = Korean

I hovered over the white text so you can see the problem.
1. The area with the white text is in original with a GREEN Background but now in Translation it is white!!! So why is WPML changing that?

hidden link
hidden link

2. Next come a huge green area in the Korean translation but in the original English one hat is White background

3. Major strangeness is the following. This page got translated with WPML and had no other translation before!!! so why is it now showing: "Real Health Care Reform"
in the translation - and that is NOT Translated to Korean even the Koren translation has been added in the translation manager already as you could see in the backend if you would access it - you have already access details!!!

---
PLEASE open the original page in one TAB and the translated page in another TAB and again the translation manager for that page in another TAB.
---

Now scroll down to about the middle and you will see the following in the KO translation
hidden link

Again the background color had been changed as now the are with all Conferences News | Schedule | Videos | Album | Papers | Delegates | Certification | Venue | Contacts is now with WHITE Background and NOT like in the Original English Page with a BROWN Background

4. Now scroll down again a bit more and you will see that the translation is actually WORKING (question is why not for all the other fields or areas)
The Newsletter shows a Korean translation and that is like the other fields a GLOBAL Element too. BUT the title did not get translated. This shows us that the GLOBAL Element title does not translate but that the translation of the plugin works - perhaps because it has already a ko translation in the plugin 😉 which means the translation is not coming from WPML at all.

in KO it looks like that
hidden link

and in the original page it looks like
hidden link

5. Now again scroll further down
and here in the ORIGINAL you see the correct design and background colors and Text formatting
hidden link

When you now change and compare that with the KO translation you can clearly see the GREEN Background which differs from the original and you can also see that the TEXT formatting had been changed - I am asking you why, when the translation manager is translating only the text on the page.
Check ko:
hidden link

and you also can clearly see that the area BELOW the green area is with WHITE Background while the same area in ORIGINAL is with a golden background.

Besides that even all those areas have already been translated in the backend, NONE of the translations are showing up!!! You can check the translations yourself if you would enter the backend at least one time to check 😉

- - -

So I would say we start working professionally on finding a solution for this problem.

Step 1: ACCESS THE BACKEND AND CHECK YOURSELF!

This avoids writing forth and back always the same thing and getting standard solutions from you which most we already found ourselves.

Step 2: OPEN UP DIFFERENT TABS SO YOU ACTUALLY CAN COMPARE THE ORIGINAL AND TRANSLATION BEST ON TWO SCREENS OR IN A SPLIT SCREEN SO YOU CAN SEE THE PROBLEM!

It really would help if you wold do that and don' come back with trying to separate any issues here as first of all the issue is a complete and not a separated issue which you would realize if you do what I wrote above.

TAB 1:
Access the backend in on TAB and check the same page in Translation manager

TAB 2:
Open the page in original - hidden link

TAB 3:
Open the page in Korean translation = hidden link

TAB 4:
Open the page in Korean translation AND !!! (important) ENABLE the Frontend Visual Builder
hidden link
that is very important as then you can see that the formatting in the Visual Builder is OK - but still the text does not get translated.

TAB 5:
Open the Page EDIT, so you can see the right column in the backend
hidden link

- - -

Some additional Findings:
hidden link

Here you can see in TAB 4 (Visual Builder) that the events get listed.
But when that Visual Builder is NOT active then those events get NOT listed anymore! - TAB 3
simply compare!!!

hidden link

I made the screenshots WITH The URL so that you can SEE that those problems EXIST ON THE SAME PAGE!!!

It simply does not make sense to talk now already about the translations of all other over 150 pages one by one - as long as that single page not even displays correctly.

================

SO NOW TO THE ACTUAL PROBLEMS:

MAJOR PROBLEM 1:
NO TRANSLATION SHOWS UP AT ALL WHICH GOT DONE BY TRANSLATION MANAGER

but the rewrite seems to work and the Korean language seems to get recognized as the Newsletter Module Contact Form gets translated to Korean Language and also parts of the Backend top bar get translated to Korean Language - which is contra productive as the translator or developer (like me) is not capable to read Korean language but it translates even he has set his language to ENGLISH for the backend! SO why are Korean translations suddenly appearing in the backend when checking a Korean Page! 😉 as Admin with ENGLISH settings. This is definitely a WPML problem as WPML does not separate the Editor Language in the Backend with the translation of the page! This needs to get fixed - Modern CMS like Drupal, TYPO3, Processwire etc don't have such major problems for Editors and Admins, here the Language stays the same in the backend EVEN content of a page gets translated for the frontend.

SO NO TRANSLATION SHOWS UP NEEDS TO GET FIXED FIRST
important as even when focus on Footer stuff that has to work at first place!!!
So WHY IS THE TRANSLATION NOT SHOWING UP!

You have access to the backend.
You have the debug file with all settings
You have the wpm settings file with all settings

What is your SOLUTION so that the translation shows up!!!

First we need to solve that problem before all others.!

- - -

PROBLEM 2

Now go TOP to BOTTOM
WHY IS WPML CHANGING THE BACKGROUND COLORS???

- - - - - -

PROBLEM 3
WHY IS WPML NOT TAKING THE ORIGINAL TEXT!!! but instead a text of a very very old revision!!!
"Real Health Care Reform" in KO translation
"Transforming Healthcare Through Lifestyle Medicine" in Original

So why is WPML Translation Manager not taking the original Text???
If that would have been translated to Korean I probably would not even have realized that WPML is taking revisions instead of the current live version TEXT

PROBLEM 4
WHY DOES THE EVENTS LIST GET NOT DISPLAYED --- AND AGAIN CHECK THE TITLE ON THE LIVE SITE ORIGINAL AND TRANSLATION --- ALSO HERE A REVISION IS ACTIVE INSTEAD OF CURRENT LIVE!!

hidden link
In Original its says "Upcoming Worldwide Conferences"

WHICH IS MISSING IN TRANSLATION and instead you can read
hidden link

"Conferences and more – Book Now!
(no Extra fees get charged when booked on aslm.asia!)"

Which is not even existing on the live Page!!! as it comes from a very very old revision.

And when you enable the Visual Builder on the translation you can see that the events Module is actually there correctly - so why is it not showing when the Visual Builder is NOT active.
hidden link

==================

So as you can see you have to follow a complete different approach to solve problems as those problems are consistent on ONE SINGLE PAGE all together.

A SOLUTION therefor has to provide the following:
1. Translation has to show up
2. The current Version needs to be taken ALWAYS to translation Manager and not a revision of a page
3. The Design and CSS Values need to stay in place all the time no matter what translation

- - -

So as you can see here there are only the three things which are connected with each other probably.

WHY?

It could be that the paths get read wrong by WPML and that could be caused by wrong settings for WPML - Have you checked that all settings are correct like we have done them?
You need to ACCESS the BACKEND.

If a path iOS wrong probably also css get read wrong. I doubt that this is the reason as not all CSS values change - only backgrounds and the Quotation Formatting. But the Titles and other Text stay the same!

So what else could be the problem?
Perhaps the Translation Manager has a problem by taking one part of tea and writing it back into the same container and instead it is writing and creating a container before it. so the title is soddenly white background (Before Green) but the text below has now Green Background and was before White in Original etc. But it does not explain where the GREEN background below the Contact Form is coming from as there is no Green background before!!!

This means that the problem is perhaps NOT caused by the current content but again by an olderRevision which was at one point perhaps GREEN Background.

A solution to check that would be to be able to DELETE all existing Translations so that NONE of those translations would exist anymore also no revisions of any elements.

We have in TOOLS - DB Tools - available and here you can see that the revision got deleted already - BUT still the OLD title and perhaps Old green background of the Quotation part shows up - WHY ->> this means WPML is taking information from the database (one option) or it is taking an old version stored already in the Translation Manager from a former installation of WPML under the same domain!!!

We have no access to the translation Manager as that runs from your site, so only you can check that.

===========

FAZIT

As the Global Elements present on that page got translated already but still the translation itself does not show up you have to focus on something else than on the FOOTER as focussing on that will BLOCK ANY progress as you won't solve the Footer Issue without solving the other Issues before as they are related and BASE of the problems in the Footer - which is actually not at all a FOOTER problem as what you see here as FOOTER is nothing else than a GLOBAL element like you see it also in the HEADER 😉 You would have realized that already if you would have ACCESSED the BACKEND and opened the TABS as written above.

So let's work like PROFESSIONALS and not like a HOBBYIST - I hope you agree - or better transfer the problem to your supervisor. Thanks!