Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Carlos Rojas 1 year, 2 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 11, 2019 at 4:14 pm #4555249

timF-10

Hi,

We've had issues with the "Sort by popularity"-feature of WooCommerce. On our Belgian website hidden link it works fine and displays the correct most popular products.

However, the Dutch version, hidden link displays the most popular product at the end of the list, which doesn't make any sense.

Since "Sort on popularity" is based on registered total sales of a product I dug deeper and installed Woo Total Sales, which displays the registered total sales.

Not a single product displayed any other total_sales than 0. On hidden link it displayed the correct number of sales.

So my question is: what could be causing the total sales only to be registered on the Belgian, original version and not on the Dutch, translated version?

Many thanks,

Tim Fockedey

September 12, 2019 at 9:10 am #4559719

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Los_Angeles (GMT-08:00)

Hello

I was able to easily recreate this issue on a new installation and confirm that indeed, the post-meta field total_sales is not being syncrhonised as it should be.

I´m reporting this bug to our developers. Please check in from time-to-time to check on the status of the fix here. Once I have news of any progress, I will also update this same ticket.

Do you have any quesitons before I escalate this to our 2nd tier group for work?

September 12, 2019 at 10:29 am #4560233

timF-10

Hi Yvette,

Glad you were able to replicate the bug and it will be resolved. Any idea how long this might take? Since the products aren't sorted as they should be it hurts our conversion rate badly.

Thanks for your quick support!

Tim

September 12, 2019 at 10:35 am #4560255

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Los_Angeles (GMT-08:00)

I cannot say but being that this is really a core Woocommerce feature, my guess is that it will certainly be prioritised once it gets into someones hands.

The official correction might only be delivered in the next release of WCML but I am confident that a temporary fix will be provided to you as soon as they can.

September 12, 2019 at 10:35 am #4560257

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Los_Angeles (GMT-08:00)

I cannot say but being that this is really a core Woocommerce feature, my guess is that it will certainly be prioritised once it gets into someones hands.

The official correction might only be delivered in the next release of WCML but I am confident that a temporary fix will be provided to you as soon as they can.

September 12, 2019 at 11:14 am #4560403

timF-10

Ok, thanks a lot!

September 24, 2019 at 5:40 pm #4633287

timF-10

Any news on this issue? Any way I can already resolve it?

September 24, 2019 at 10:12 pm #4634351

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Los_Angeles (GMT-08:00)

Hello

A solution has been found but not yet fully tested. I can see it is scheduled for testing and will most likely appear in the next release.

Without full testing, I would hesitate to offer the code changes for implementation. Additionally, the fix has only been developed on our development versions so you would not have the latest code. I would just keep downloading the most recent versions of WCML and testing to see if that version has the fix implemented or not.

I´m sorry I cannot give you a more precise date or instruction.

September 25, 2019 at 6:50 am #4636063

timF-10

Ok, great! I'll keep an eye on the next release!

September 27, 2019 at 2:22 pm #4654939

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
My name is Carlos and I will be taking this ticket from now long because our colleague Yvette is on vacations.

Thank you very much for your understanding regarding this issue. As my colleague mentioned in her previous message, our development specialists are actively working on a final solution for this ticket that should be included in the next release of the plugin.

Best regards,
Carlos

The topic ‘[Closed] Total_sales not calculated correctly for domain-based translation’ is closed to new replies.