Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by veraW-2 2 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
August 19, 2020 at 4:12 pm #6832213

veraW-2

Hola
Estoy usando un theme Enfold y tengo sitio ingles - alemán (idioma primario).
tengo el siguiente problema:
Selecciono posts (Beiträge) y seguidamente selecciono la banderita inglesa para ir a ver solamente los posts en ingles. Cuando hago esto último, me muestra los posts en aleman y si se me ocurre editar alguno de estos posts el cambio se ver reflejado en el post alemán.
Para poder ver los posts en ingles debo ir al combo box "All categories" y ahí si, me muestra las categorias en inglés y si selecciono alguna, recien ahí me muestra los posts en inlgles.

Si, por el contrario, voy al lado aleman (selecciono banderita de alemania de arriba) ahi me aparecen todos los posts en aleman pero no teng ningún botón que me permita realizar la traducción al inlges a partir de ese post en alemán.

Espero haber sido claro si hay alguna duda con gusto les aporto la información que necesiten

August 19, 2020 at 7:19 pm #6833333

veraW-2

Hi there! here is my request in english because I need urgent assitance.

.....

Hello
I'm using an Enfold theme and I have an English-German site (being german the primary language).
I have the following problem:
I get logged in, I go to WP dashboard and
select "posts"(Beiträge in german) after that, I select the English flag (from the upper black bar) to go to see only the posts in English. When I do the latter, it shows me the posts in German and if I try to edit any of these posts the change will be reflected in the German post (So i infere these are not the "english posts").
To be able to see the posts in English I must go to the combo box "All categories" and then yes, it shows me the categories in English and if I select any, just there it shows me the posts in English.

If, on the other hand, I go to the German side (I select the German flag above) there, I see all the posts in German but I don't have any button/icon that allows me to translate these german posts into English.

As a result of this problem, I can create englsh posts from scratch and asign them english categories but somehow there is no connection with their german counterpart post...not sure if I explained myself clearly

I hope I have been clear if there is any doubt, I will gladly provide you with the information you need

August 20, 2020 at 8:27 am #6836587

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hola!

1) Para poder entender mejor tu situación, me sería útil tener la información de Debug de tu ambiente de trabajo.
Por favor sigue los pasos en este documento y luego inserta la información aquí en el forum, en el campo apropiado: http://wpml.org/faq/provide-debug-information-faster-support/
( por favor no lo agregues en el campo "respuesta" sino en el campo que he activado para tu próxima respuesta)

Esto de arriba te lo pregunto porque si te falta algún requisito minimo de WPML, se podría crear el problema y no quiero continuar sin saber si es tu caso.

Saludos.

August 24, 2020 at 1:25 pm #6860101

veraW-2

Please let me know if this is the information that you requested.

Thanks

August 24, 2020 at 4:12 pm #6861429

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Comencemos por cumplir con los requisitos minimos de WPML:

Por favor agrega el siguiente código en el archivo wp-config.php de tu configuración, justo luego de la información de la base de datos:

define('WP_MEMORY_LIMIT','256M');

Luego trata de revisar de nuevo la situación y si es posible, usa un instrumento como hidden link para grabarte en un modo sencillo y veloz cuando haces estas pruebas. En fin, envíame esa grabación para ver mejor que es lo que pasa, y sobretodo para ver los pasos que usas.

Así sabré cómo continuar.

Saludos.

September 1, 2020 at 3:09 pm #6917969

veraW-2

Hello how are you?

I did what they requested (I increased the 'WP_MEMORY_LIMIT', '256M') but it still doesn't solve the problem.

Just in case I describe the problem in a little more detail:

I have a German site translated into English

If I am positioned in "posts" in German language (small German flag selected in the upper menu bar) it shows me the posts in German as well as in English indistinctly (it is wrong) but if I look at the combo box to select the categories, then It will only show me the categories in German (which is correct). When I select the English flag (with the intention of seeing only the posts in English) it will continue to show the posts in both languages, although if I look at the combo to select categories it will show me only the categories in English.

I also have no way of translating German posts since it doesn't show me the + symbol to start the translations.
The posts in English that I have at the moment are very few and are from the time when wpml allowed me to do translations.

September 1, 2020 at 3:22 pm #6918115

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

you said:

...I also have no way of translating German posts since it doesn't show me the + symbol to start the translations.

This is indeed weird but it might be happening because posts are set as "not translatable". please check that in WPML > Settings > Post Type Translation.

Make sure both "posts" and "pages" are set to "translatable - Only show translated items".

Then you mention:

it shows me the posts in German as well as in English indistinctly

this sounds like the "All Languages" setting in the overview page for posts which is also another link like "German" or "English". however this should not be selected by default so this is indeed weird.

------------

To continue, i'd like to ask you to create a staging site and disable there all the plugins and the theme for a moment and check if the same behaviour continues to happen.

If it does then please try the following:

❌ Before proceeding please make a full website backup! ❌
Go to WPML -> Support -> Troubleshooting
Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix post type assignment for translations".

Let me know how this goes and if any of the steps helped you fix this.

September 11, 2020 at 1:58 pm #6994425

veraW-2

El problema quedo resuelto