This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by nikolajW 2 weeks, 6 days ago.

Assigned support staff: Raja Mohammed.

Author Posts
September 26, 2019 at 5:53 am #4643595

nikolajW

Hello,

see video for demonstration.
hidden link

The checkout page of a manualy created order is appearing broken after switching the language.
The Link is looking like this:
Original: hidden link

Tranlated: hidden link

This string in URL is missing.
pay_for_order=true

Regards

September 26, 2019 at 9:24 am #4645061

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The issue has been escalated to second-tier.

September 26, 2019 at 10:00 am #4645485

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I think I have solution here,

Goto WPML > Language > Language switcher options, click on "Preserve URL arguments" Add pay_for_order and save. This fixed the issue in the sandbox site already. I hope this should work for you as well.

https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#preserving-url-parameters

September 29, 2019 at 1:28 am #4659465

nikolajW

My issue is resolved now. Thank you!

September 29, 2019 at 1:29 am #4659467

nikolajW

Ouh by the way, this issue will be resolved in another way in future updates or do I have always to add the string to preserve the URL?

September 30, 2019 at 3:57 am #4662155

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This is a case of an exception and hence we don't have any plans to add that to the core.

I would suggest continue using the preserve URL parameter as this is the available solution for now.

October 3, 2019 at 2:02 pm #4688513

nikolajW

My issue is resolved now.
Thank you!

I hope that there is no other situation I'll need to use antother preserved URL. 🙂