This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Mihai Apetrei 8 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
February 4, 2019 at 6:14 am #3156399

avinashG-2

I am trying to: translate megamenu

Link to a page where the issue can be seen: Header of the website

I expected to see: Translated "Shop department" is not showing up

Instead, I got: Instead it is showing up in English

February 4, 2019 at 7:01 pm #3159219

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

The way to translate those strings really depends on how they have been added.

1. Can you please let me know if you tried to go to WPML > String Translation and search for of the words in those sentences?

Here is some very helpful documentation on how to use the String Translation plugin:
https://wpml.org/documentation/getting-started-guide/string-translation/

If it's not there, it could help if you scan the plugin that's generating the strings and then go back to WPML > String Translation and see if the strings show up:
https://wpml.org/documentation/getting-started-guide/theme-localization/

2. If you can't find it inside the WPML > String Translation, it might be added as admin text.

This should be the normal process to translate admin texts:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

If you still can't find it, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

February 11, 2019 at 7:44 am #3181110

avinashG-2

I have done translation for those string by searching as you have mentioned. but still it is not showing up

February 11, 2019 at 1:13 pm #3183025

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

It seems that button is added in Appearance > Menus

All you have to do is to go into the translation page of the menu here (hidden link) and simply update the text of the first button to whatever you want.

I made a test already (I am attaching screenshots) and it works.

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai

February 11, 2019 at 1:17 pm #3183060

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

From what I can see, however, even if we translate the name of the first button, the rest of the menu is not displaying so probably this is what you were referring to.

Can you please let me know if following the steps in the ticket below solves your issue?
https://wpml.org/forums/topic/split-wpml-elementor-footer-not-translating/

I will be waiting for your response.

Mihai

February 15, 2019 at 5:36 am #3202862

avinashG-2

It did not help. Please suggest something else

February 15, 2019 at 4:41 pm #3206004

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I see.

Can you please let me know from where exactly you have created this mega menu? I did not work with this plugin before so it would help if you can give me a link or some screenshots.

I could see the shortcode in the screenshots I attached and I assume the menu it's added in the "Templates" but I get a 500-error when I try to visit that page.

Please let me know.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

The topic ‘[Closed] tranlated menamenu is not showing up’ is closed to new replies.