This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
May 5, 2018 at 5:54 am #1986733

dermitzakis-bros-s.aD

I translated 2 pages of my web page, but nothing shows, only background. I use divi builder.
My webpage is hidden link, and I have translated Home page and who we are -> factory page. If you click in Greek language you will see nothing show. I also need help to translate menu buttons.

May 7, 2018 at 3:40 pm #2015646

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following steps and make sure you are getting the expected result for the translated pages.

1) Visit *Dashboard>>Updates* page
2) Click on *Update* button of *Theme and Plugins compatibility with WPML* section
3) Make sure the translation of pages are completed to 100%
4) Update the original language pages after a minor edit to refresh the translation settings
5) Open the translation again for editing in Translation editor
6) Update the translation

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

Please open a new ticket for the following issue. Because as per our support policies, we can only handle one issue per ticket. You can assign the new ticket to me by mentioning my name on it. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. Thank you for the understanding.

I also need help to translate menu buttons

--
Thanks!

Bigul

May 8, 2018 at 3:45 am #2022908

dermitzakis-bros-s.aD

I have done all the steps you indicate but problem still the same.
Please have a look the pictures. the same page in English and translated in Greek.

May 8, 2018 at 1:26 pm #2031509

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Maybe it will be happening because you are using the older version of Divi theme - hidden link. Please upgrade to the latest version of Divi theme after full site backup and check you are still having the issue.

If you are still having the issue, please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

The topic ‘[Closed] Tranlated page shows only background – Menu translation help.’ is closed to new replies.