Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 2 voices.

Last updated by jean-paulS 3 months, 4 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 15, 2019 at 8:52 am

jean-paulS

I am trying to: translate the cookie consent strings

Link to a page where the issue can be seen: EN: hidden link, NL: hidden link

Hi, I have an issue with the GDPR Cookie Law plugin (by Webtoffee) and WPML string translation on my bilingual website (EN-NL).
When I translate the strings of the “admin_texts_CookieLawInfo-0.9”, and I refresh the String translation page or I log out and log in again, the translated strings appear instead of the English ones.
In the Cookie Law Settings, sometimes the text is still in English, and sometimes it is in Dutch too.
And sometimes, when logging out and in again, the Cookie Law widget is in English on both parts, and the strings "need translation." When checking again "translation is complete" and saving, the widget remains in English.
I tried different ways to get the strings right but in vain.
I cleared the cache of WPML, but no result.
I also deactivated all my other plugins, but this didn't solve the problem.
Could you take a look at it?
Kind regards.
Jean-Paul

April 15, 2019 at 9:58 am
April 15, 2019 at 10:52 am #3612625

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The issue is resolved in chat. Instead of marking it as resolved. moved to the forum.

Closing as resolved.

Regards
Raja

April 15, 2019 at 12:38 pm #3613449

jean-paulS

Hi again,
I looked again in all different browsers, and the cookie text appearing on the English site is in Dutch again, thus not only in Firefox. And in the Cookie Law settings, the text is still in English, but in the string translations, the English text swapped to Dutch. So it has nothing to do with the browser, unfortunately. Something must act as a trigger to swap the language of the strings. Needs more investigation I'm afraid.

April 15, 2019 at 12:50 pm #3613519

jean-paulS

In Cookie Law Settings > "Advanced," I "Delete settings and reset", and it seems to work. I could log out and log in again. But when I renew the page with the string translations, the English strings changed to Dutch again.

April 16, 2019 at 4:35 am #3618153

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jean,

Please share temporary access to the site again. let me investigate the issue further. Enabled private reply for you to securely share the details.

Kind regards
Raja

April 16, 2019 at 6:28 am
April 16, 2019 at 2:00 pm #3622675

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the access, This is quite strange. To understand and isolate the issue. Please install the GDPR consent plugin to the sandbox site hidden link ,

Please try to reproduce the issue. WPML plugin is installed in the test site please activate and complete the setup, You don't need to clone the entire site. Just install the GDPR consent plugin and related functionality.

Let's try to figure out if the issue is related to the plugin or with the server cache.

Let me know once done.

Kind regards
Raja

April 17, 2019 at 9:54 am #3629299

jean-paulS

Hi Raja,
Found finally the time to test in the sandbox site. It works when in WPML>Languages>Language URL format I choose "Different languages in directories or "Language name added as a parameter", but of course I can't test it with a subdomain (which is the setting on my website). Is it possible to create a subdomain for this sandbox site? Unless you're sure it will work too...
Kind regards

April 17, 2019 at 9:56 am #3629315

jean-paulS

Oops, I was too fast. I just renewed the string translation page once again, and the English strings changed into the Dutch one. So, same problem here...

April 17, 2019 at 10:02 am #3629363

jean-paulS

And also here, the Cookie Law Settings are affected: all the English, default messages are translated to the Duch ones.

April 17, 2019 at 12:58 pm #3630929

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jean,

I am unable to reproduce the issue. performed these steps,

1) Added an English text in Cookie law setting message box

2) Updated translation in WPML > String transaltion

3) Updated English text in Cookie law setting message box

4) Repeated step 2

I don't see any issue here. I have recorded my actions please refer hidden link

Can you please confirm the same?

Kind regards
Raja

April 17, 2019 at 3:42 pm #3632407

jean-paulS

Hi Raja,
First, I did the same as you did (and it worked indeed), and afterward, I pasted the complete English text again in the Cookie Law Settings + translated the strings in Dutch. This was with the use of the URL format "Different languages in directories" with the URL "hidden link - Dutch" for the Dutch website (in WPML>Languages). In the translations, I used this as a translation of "hidden link." Everything worked fine.
Then, in WPML>Languages, I changed the URL format to "Language name added as a parameter," with "hidden link - Dutch" as URL, which I used as translation in the strings. After renewing the String Translation page, the default English strings changed to Dutch again (leaving the Cookie Law Settings unchanged this time.
Renewing the String Translation page once again shows the English strings again, but this time with a slash before each truncation sign and quotation mark (We\'ll assume you\'re ok with this.[cookie_button margin=\"5px\"] [cookie_link margin=\"5px\"] ), and every translation "needs update," although the translation is already there. Without saving the translations again, the text appears in English on the Dutch website. After saving the translations: everything ok.
Then I switched back to "Different languages in directories" (with "hidden link - English, hidden link - Dutch" as URL again), and also this time, the English strings change to Dutch without affecting the Cookie Law Settings, but they remain in Dutch, even after renewing the String Translation strings several times.
But after updating the Settings, everything is normal again.
Of course, I don't have to change the URL format all the time, but I do this for testing purpose of course. And also because it has maybe something to do with the subdomain as URL format (on my website).
To make a long story short: on the sandbox, it works with both URL formats available.
Kind regards

April 19, 2019 at 5:38 am #3643661

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jean,

Thanks for the detailed explanation and your patience. It seems like the issue is very much related to your setup can you please install Phpmyadmin plugin for WordPress https://wordpress.org/plugins/wp-phpmyadmin-extension/#installation, this enables me to check for any corrupted database entries related to your issue. The plugin will be deleted after the issue is identified and fixed.

I would also request your consent to access the database. I can confirm there won't be operation from my side I just want to check for any abnormalities.

Kind regards
Raja

April 19, 2019 at 7:00 am #3643781

jean-paulS

Hi Raja,
I have installed the Phpmyadmin plugin, but couldn't "enter phpMyAdmin" in WP. But I see that I already have it in cpanel. To login manually, the phpMyAdmin login page URL should be pasted on the login page of the plugin. I will leave that up to you.
For consent for access to the database: no problem. I can send you an FTP account with login and password. Please provide me a secure way to do this.
Kind regards
Jean-Paul