This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by martinL-61 5 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 2, 2019 at 6:41 pm #3728345

martinL-61

Tell us what you are trying to do? Display portfolio items in a different language.

Link to a page where the issue can be seen:
hidden link

I expected to see:
A translated version of hidden link

Instead, I got:
Nothing hidden link

May 2, 2019 at 8:14 pm #3729003

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support.

How was the custom post type created? Is it a part of the theme?

Could you please go to WPML -> Settings -> Post Type Translation and verify if the post type is set to "translatable"?

If this will not solve the issue it might be better if I take a look at the site.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 2, 2019 at 8:50 pm #3729209

martinL-61

Hi @andreas

Thanks to look at this problem for me!

Post Type Translation are set to copy but I have tried with "translatable" without any success.

May 2, 2019 at 9:44 pm #3729321

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far I can see everything is translated properly but there is a issue when selecting the icon to show all items, corrects?

Both pages do not have any written content, but the titles and images are translated. The URLs are correct. By clicking on the arrow on tthe right you can switch through the different items and they also appears a s translated.

Anyhow, I realized an issue once the list icon on the left top is selected in order to display all the items. The category filter are not working, although they are translated with WPML.

The issue seems not to be realted to WPML, as the category filters neither work if WPML is deactivated. Please enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Once you obtained the debug.log file please send me the results. I would also recommend you to contact the theme support in regards to the portfolio filter issue.

Kind regards
Andreas

May 3, 2019 at 8:28 pm #3737847

martinL-61

My issue is resolved now. It seems to be a ghost problem. After your investigation, I noticed that the language selector was gone. So I decided to restore the backup made before your intervention and everything have been working good since then like there never been any issue. I hate that! Thanks for your investigation Andreas.