Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by sandrineD-2 6 days, 14 hours ago.

Assigned support staff: Alejandro.

Author Posts
November 19, 2019 at 4:54 pm #4974479

sandrineD-2

Since fews days all my translated products making error 404

i didn't do anlything on the website

Could you help me please ?

I tried to do this : https://wpml.org/forums/topic/translated-product-showing-404-error/
but not working for me

November 19, 2019 at 5:28 pm #4974749

Amit
Supporter

Hi, can you please update to WPML 4.3.4 (including your needed add-ons) and let us know if that issue was not fixed with that version.

November 23, 2019 at 7:04 am #5002773

sandrineD-2

HI

thanks for your answer, we updated WPML & addons but the problem is still there 🙁

November 23, 2019 at 1:39 pm #5004283

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

Please try the following steps:

- First of all update the plugins that still require updates (String Translation to version 3.0.4, WooCommerce Multilingual to version 4.7.4), you might've done this alraeady but i want to just have a confirmation of it, please.

- Please add the following code in your wp-config.php file, right after the database information lines of code, to meet our minimum requirements:

define('WP_MEMORY_LIMIT','256M');

- Once all that is done, please go to settings > Permalinks and make sure every field is correctly setup (so, do not leave any field empty, specially category bases, attributes base, etc)

- Go to WooCommerce > WooCommerce Multilingual > Setttings > Troubleshooting > Select all the options there and press the button "apply" (this step will synchronize every product and taxonomy).

- Last but not least go to WooCommerce > WooCommernce Multilingual > Store URLs > Make sure you translate all the pages in there.

That should do it.

Let me know how it goes.

November 24, 2019 at 9:53 am #5006197

sandrineD-2

Hi

thanks for your help
i did all the steps but nothing changed 🙁
hidden link

What can i do ?

Thanks

Augustin

November 25, 2019 at 12:38 pm #5012017

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

To continue, I think i can only take a look at the site now to inspect and see what's going on and to do that i'll need temporary access to your site.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

November 27, 2019 at 6:26 pm #5031851

sandrineD-2

sorry for admin is not wpml-admin only : wpml

November 28, 2019 at 10:38 am #5034947

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

The problem was that both "produit" and "categorie-produit" had the same slug in english: "product" that created an error and ended up showing you the 404 error.

you can check this in WooCommerce > WooCommerce Multilingual > Store URLs

Remember that the slugs must be unique and you should not have the same slug for different things accross the site.

hidden link

Regards.

November 29, 2019 at 5:53 pm #5045365

sandrineD-2

Thanks a lot and sorry for the disturb, it works