Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 3 voices.

Last updated by Radu 1 year, 1 month ago.

Assigned support staff: Radu.

Author Posts
May 26, 2020 at 6:32 pm #6222825

roxanneS

Tell us what you are trying to do?
Create an attribute called "Units per box". I want to translate the label to French "Unités par boîte", but NOT the associated values since they will be numerical.
If I check the "Translatable?" box in the attribute, it will allow me to translate the label. However, it will also force me to translate all of the numerical values. How can I just translate the label?

Is there any documentation that you are following? Yes - the standard documentation.

Is there a similar example that we can see?

What is the link to your site?
hidden link (currently in the process of building) - To see the production site go to hidden link

May 28, 2020 at 11:32 am #6238567

roxanneS

Have you been able to look into this question?

May 28, 2020 at 1:00 pm #6239657

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

While you are waiting for one of my colleagues to take this ticket and work on it, let me provide you with first debugging steps or if I can perhaps help with the issue quickly.

Did you try translating the label only by going to WPML -> Taxonomy Translation -> Select the taxonomy to translate: -> Select yours -> Translations of taxonomy (your label) labels and slug

Regards,
Bruno Kos

May 28, 2020 at 1:19 pm #6239941

roxanneS

This is what I have tried:
1) WPML Settings // Taxonomies marked as "Not translatable". Results: the taxonomy label is not available in the dropdown field in WPML > Taxonomy Translations. So I cannot translate the label.

2) WPML Settings // Taxonomies marked as "Translatable - use translation if available or fallback to default language". Result: Yes, I can translate the label. However, the numerical values are not showing in French when there is no translation. Therefore it does not fallback to the default language. I does this for both existing values and newly created values.

May 28, 2020 at 8:26 pm #6243629

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Roxanne,

Thank you for reaching out to the WPML support!

Can you go to WooCommerce → WooCommerce Multilingual → Status tab → Troubleshooting link (bottom right corner), please? Here, just simply use the Duplicate terms (please select attribute) option, and select the attribute that you'd like to duplicate its values.

Once you do this, the values of the attribute should be copied to the other languages, as you are looking for. Can you give this a try and tell me how it goes for you, please?

Thanks,
Radu

May 28, 2020 at 9:01 pm #6243715

roxanneS

Unfortunately, this does not fix the problem.

May 28, 2020 at 9:40 pm #6243897

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Roxanne,

As I can see, the WP memory limit on your website is 40M (you can check this through WPML → Support). In order to have all the WPML features work well, please increase this value to 128M (256M recommended - https://wpml.org/home/minimum-requirements/).

Once you made this change, try again to use the option from the WooCommerce Multilingual area (the one I mentioned in my previous message) and tell me how things work this time.

Thanks,
Radu

May 31, 2020 at 3:47 pm #6260843

roxanneS

I updated the site to the minimal requirements. Then, I used again the Sync variables tool. It still does not work.

June 1, 2020 at 1:57 pm #6266035

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Roxanne,

Can you give me access to the dashboard area and a link to one of the products where I can see the attribute values that you'd like to copy, please? I will check this out and see what is going on.

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

June 3, 2020 at 7:57 am #6280491

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Roxanne,

I checked the Tortilla Tilapia product in English:
hidden link

and in French too:
hidden link

When I go to Attributes → Unités par boîte and Cuisson, I see the same values as in the English version.

Can you tell me if there's anything else I should be checking, please?

Thanks,
Radu

June 3, 2020 at 2:28 pm #6284781

roxanneS

OK, apparently the duplicate terms eventually worked. However, your solution does not really address the problem. Specifically, regarding the setting "Translatable - use translation if available or fallback to default language" for a taxonomy.

For example, I just added the value "100" to the Units per box on the Tilapia. If I look at the French, I expect to see 100 even if it's not translated, because the setting indicates that it will fallback to the English in the absence of a translation. Instead, I see nothing.

It seems ridiculous that I must launch the duplicate function when it's supposed to display a default value.

June 9, 2020 at 7:16 am #6327503

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Roxanne,

If you go to WPML → Support → troubleshooting option and use the Synchronize posts taxonomies button for the products, you should be able to see the attributes in the translated product with no problem.

I asked my colleagues for some more info regarding the option from WPML → Settings to see why is the attribute not appearing automatically, without needing to be duplicated. I will keep you posted about this as soon as I have any news from my colleagues (which shouldn't take long).

Thanks,
Radu

June 23, 2020 at 10:39 am #6433677

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Roxanne,

Sorry for taking this too long to reply back. I talked with my colleagues and I think that I was finally able to find a fix for this. Please go to Products → Attributes, edit the attribute you're using, and make sure that the Translatable? option is unchecked. This way, the terms should appear on the translated product, without having to add a translation for them.

Thanks,
Radu

June 23, 2020 at 1:36 pm #6435407

roxanneS

Perhaps you should read the whole thread again, because your answer brings us full circle to the original problem. If Translatable? is unchecked, I cannot translate the Label. I set the field to "Translatable - use translation if available or fallback to default language". This should technically allow me to translate the label and leave the numerical attributes untranslated, which should then fall back to default.... which it is NOT doing.

June 23, 2020 at 7:29 pm #6437553

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Roxanne,

Sorry about that. I forgot about the initial request, that you'd like to translate the attribute label but use the same terms in the translated products. As far as I know, this is not possible but I asked my colleagues again for a little help, to see if there's something I'm missing out. I'll let you know what we find about this.

Thanks,
Radu