This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

This topic contains 47 replies, has 2 voices.

Last updated by Jamal 3 months ago.

Assigned support staff: Jamal.

Author Posts
June 19, 2019 at 1:44 pm #4051875
kevinS-10

Tell us what you are trying to do?
I create Home Page & Many Another pages with ACF Pro in my default Language, And i getting all data using Page Template. Now i need to translate my whole site in another language.
I create Fields with ACF like True/False, Clone, Groups, Repeater and many more type, and i use conditions with ACF values in Template.
I translate my page with WPML, and need to translate some ACF fields values also, but i need some ACF fields value as it is like Parent language like Background Color, height, Background Image those we don't need to translate so need to Copy As it is Main Language.

So when i translate a page in another language it looks Blank because all data is not Translated. Please Guide me For this.

I Have one another issue i have also installed Woocommerce for Shop Page and translate all the products with WPML i also use https://woocommerce.com/products/dynamic-pricing/ this plugin for Dynamic pricing but when we Translate Products with only Regular price to English Language then we have two Prices on front after Translation, so will you please help me to resolve this. We don't add Sale Price for any Product.
Example:
hidden link ( In Main Language with single Price )
hidden link ( In English Language )

Is there any documentation that you are following?
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

What is the link to your site?
hidden link

New threads created by Jamal and linked to this one are listed below:

https://wpml.org/forums/topic/woocommerce-sale-price-is-visible-in-secondary-language/

June 20, 2019 at 6:25 am #4056871

kevinS-10

Will anyone please Look into this asap.

June 20, 2019 at 11:36 am #4059517

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

However, for support rules, we are able to handle only one issue at the time. This helps us to bring you a better service and also help other users to find all the information here exposed. For that reason, I created another ticket about the product prices issues.

Please show me a (blank)page that is presenting this issue and allow me temporary access to your backend to check the various settings.

Best regards,
Jamal
WPML Support

June 20, 2019 at 12:00 pm #4059641

kevinS-10

Are you able to connect all things.
Or you need anything else.

June 20, 2019 at 12:25 pm #4059935

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I can see the differences between both pages. But the credentials to log in are not working for me. Would you please check if you can log in with, or provide other credentials. I activated the private box again to share credentials safely.

Best regards,
Jamal

June 20, 2019 at 1:07 pm #4060121

kevinS-10

Are you connected Now.

June 20, 2019 at 1:42 pm #4060321

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I confirm the credentials are working. I was able to connect, let me check the website and I will get back to you very soon.

Best regards,
Jamal

June 20, 2019 at 2:04 pm #4060499

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I opened the provided page, for editing, in the default language and all the custom fields are not set to be translated. See the attached image. You can click on "Show system fields" to view all the custom fields used in this page. Only a few custom fields are set to "Translate". The majority is set to "Don't translate".

You will need to set the needed custom fields as "Translate", those that need to be copied as "Copy" and probably some will remain as "Don't translate". Then click on apply at the end of the custom fields table. You will also need to make a small edit to the page to force the translation again, and this time they will be present in the translation editor.

Please note that repeater fields and their children need to both be configured.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields

Let me know if this helps resolve the issue.

Best regards,
Jamal

June 20, 2019 at 2:05 pm #4060549

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I would also recommend that you update WPML plugins to latest releases, to avoid encountering the errors that were already fixed.

Best regards,
Jamal

June 20, 2019 at 2:16 pm #4060601

kevinS-10

Thanks For the Help.

I try it many times but i don't resolve my issue, but i will try it again as you told me.

June 20, 2019 at 2:27 pm #4060623

kevinS-10

Can we set All fields in All languages like Default Language To Copy OR Translate,
Or only set in Default Language Page.

Also we need to set "Show system fields" also.

June 20, 2019 at 3:33 pm #4061005

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

We can set settings for custom fields in 3 ways, my apologies I did not mention the other ways, before:
- In the "show system fields" section: When editing a post/page/custom_post_type, we can set the translation settings for its custom fields in this section. We only need to do it in the default language.
- Site-wide settings: We can configure custom fields for the whole site in WPML->Settings->Custom fields translation. See the attached image. And notice the search box. The window in the left is the page edit screen.
- By an XML configuration, please see this articles
https://wpml.org/documentation/support/language-configuration-files/
https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/

Finally, we need to make an update to the page, to force the translation again, this way we will get the fields we set as translatable in the translation editor.

Let me know if you are now able to translate the fields. Otherwise, I can try to make a few fields translatable and show how. In this case, I'll need you to make a database backup before I can do it.

Best regards,
Jamal

June 21, 2019 at 5:21 am #4064715

kevinS-10

Thanks For the Help,
I will try it asap.

June 21, 2019 at 5:33 am #4064727

kevinS-10

And if i set Don't translate for any fields like background Color, Height, width etc. Fields then can those value is available in Another language or need to set Copy/Translate For those fields.

June 21, 2019 at 9:24 am #4065719

kevinS-10

Hello,

Are you there, will you please look into this asap.