Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.78 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by setyo-hadiJ 1 year, 6 months ago.

Assigned support staff: Otto.

Author Posts
July 7, 2018 at 2:16 am #2472029

setyo-hadiJ

This is my frist multilangual website, please forgive me for a dummy question.

My multilangual website and active. I didnt get any problem when instaled WPML. Such a great plugin. Then I go to my website to try switch langguages but when i try bahasa, all my post, pages, my woocomerce product is disapear.

Should I translate that thing one by one? All my content? I think that will be painfull. I have +200 pages and woocomerce product.

July 7, 2018 at 7:27 pm #2472886

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

WPML does provide automatic translation, it provides you the interface necessary to translate your WordPress installation. However, you need to manually add your translations or use an external service for it.

You've set TranslateMedia as your external translation service, you can send all your translation jobs in bulk. The process is quite smooth.

here is the workflow you need to follow:
https://wpml.org/translation-service/translatemedia/

Let me know if this points you in the right direction, please.

Kind regards,

Otto

July 9, 2018 at 3:13 am #2474705

setyo-hadiJ

Dear Otto,

I still have to learn WPML,

I try to create my translation for my shop page, hidden link

I click + menu on my pages dashboard admin, click " Copy all fields from original", then check all "Translation is complete" until status bar on bottom show 100%.

then i click save and close.

after I check on my dashboard > Pages > Indonesia. I still cant found my shop page translation. Am I doing wrong?

July 9, 2018 at 11:36 am #2476041

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

The steps you mentioned are fine.

The translated catalogue page is here:
hidden link

Don't you see the page in Dashboard > Pages? Is that the issue?

May I take a look at the site?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link
 
Thanks!

Kind regards,

Otto

July 10, 2018 at 3:02 pm #2482401

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I am glad you managed to solve it 🙂

However, for support rules, we are able to handle only one issue at the time. This helps us to bring you a better service and also help other users to find all the information here exposed. For that reason I have to kindly ask you to open a new thread for each issue if you need further assistance, you can assign it directly to me. In that way, you don't have to wait and we can continue working on it.

Thanks!

Kind regards,

Otto

July 11, 2018 at 1:08 am #2484887

setyo-hadiJ

Thanks Otto