This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 41 replies, has 3 voices.

Last updated by Bruno Kos 3 weeks, 5 days ago.

Assigned support staff: Bruno Kos.

Author Posts
September 11, 2019 at 9:51 pm

andreaB-8

I am trying to: translate page keeping layuot

First of all you’ve to change your host file inserting our IP to a specified domain… cause of we don’t have site live, so you’ve to manually link domain to IP
Read this
hidden link
and in your host file add this

77.104.184.16 navigazionelagoiseo.it
77.104.184.16 hidden link

after this you can show live site
DO THIS!!! WITHOUT DO THIS YOU CAN’T SHOW RIGHT SITE

you need to show this… if you see another site you don’t have do right chagnes in your PC!

Link to a page where the issue can be seen:

You'll see a lot of pages for Italian, when I try to translate and I click in + .... I copy/paste new content... but layout font and elements are different 🙁
I'd like to clone page from Italian, keeping same layout

I expected to see:

This page (EN) is missed:
hidden link

This is OK (original IT page):
hidden link

Instead, I got:

September 12, 2019 at 10:51 am #4560327

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please let me know if you had the chance to try the duplication method below (instead of using the "+" translation method):
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Please let me know how that goes.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

September 12, 2019 at 12:56 pm #4560993

andreaB-8

I read... I don't know what to do and I don't want to broke my site.

Last time that I tried buttons without know what do I lose structure.

Please I wrote what I need.... I need English page (where change text inside) with SAME layout of current IT pages.

Thanks

September 12, 2019 at 4:20 pm #4563275

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

No worries on breaking your site.

Each time when you want to do an edit on the site and you are not sure if it will break your site or not, you can use a plugin like "Duplicator" or "Snapshot" and first create a full website backup with it.

After that, if any page breaks, you can simply restore the site to the old version.

I would be more than happy to try to duplicate that page for you.

Can I have your permission to try that for you on your site?

I will first try to duplicate the current italian page and then translate it by using the duplication procedure I sent the link for above.

Please let me know if that would be ok for you.

I will be waiting for your response.

PS: Just a note that I am at the end of my shift at the moment and I will be able to get back to you tomorrow.

Kind regards,
Mihai Apetrei

September 12, 2019 at 4:22 pm #4563279

andreaB-8

I created backup of site and is OK.
Can you try fastlty to do now? I mean allow to have pages in EN with same layout than original IT and I've only to change content of text?

Thanks!

September 13, 2019 at 8:44 am #4566629

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

Sorry, last night I was out of my shift already when you wrote me.

I tried to access the backend of your site after I added the records inside my hosts file but I still receive the error that you see in the screenshot below.

Can you please check?

Kind regards,
Mihai Apetrei

September 13, 2019 at 9:31 am #4566995

andreaB-8

BUT... HAVE YOU READ MY FIRST MESSAGE??

PLEASE TAKE CARE!!!

First of all you’ve to change your host file inserting our IP to a specified domain… cause of we don’t have site live, so you’ve to manually link domain to IP
Read this
hidden link
and in your host file add this

77.104.184.16 navigazionelagoiseo.it
77.104.184.16 hidden link

after this you can show live site
DO THIS!!! WITHOUT DO THIS YOU CAN’T SHOW RIGHT SITE

September 13, 2019 at 9:32 am #4567001

andreaB-8

You don't have do what I wrote.... if you change host in right way you've to see right site...

please check

September 13, 2019 at 4:03 pm #4569985

andreaB-8

Another day passed 🙁
Please I need to fix this 🙁 🙁 🙁

September 13, 2019 at 4:20 pm #4570027

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I already added the IP in the hosts file as I mentioned above 🙂

I know exactly what you mean, I worked multiple times with the hosts file (I am attaching a screenshot for you so that you can see it added).

However, even after I added those records in my hosts file, I still receive that error.

Sorry, it doesn't work for me.

Is there any way you can upload the site on a live staging server or send me a full duplicator backup?

Documentation can be found here: hidden link

Here is a small tutorial on how to use Duplicator:
hidden link

You can use a service like dropbox or google drive to share the 2 files with me.

I will be waiting for your response.

Kind regards,
Mihai

September 13, 2019 at 4:44 pm #4570165

andreaB-8

Can you try only

navigazionelagoiseo.it

delete www

September 13, 2019 at 4:45 pm #4570171

andreaB-8

IP is 77.104.184.16

try to clean text .... could be that copy/paste has some special chars..... clean text

September 14, 2019 at 9:32 pm #4573277

andreaB-8

Vorrei poter sbloccare la situazione.... sono bloccato in questo momento 🙁

September 16, 2019 at 7:10 am #4576745

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

Sorry for the delayed response but I don't work on the weekends.

So I've cleaned the text to make sure there's no special chars and I also removed the "hidden link" version so now I have only what you see in the screenshot below.

However, I am still receiving the same error when I try to access the admin panel.

Do you think you could use the workaround I mentioned above by using the "Duplicator" plugin?

Please let me know.

Kind regards,
Mihai

September 16, 2019 at 9:35 am #4577947

andreaB-8

Here duplicator

hidden link

hidden link

Today I've a strange issue.... I've to rename child theme for access to backoffice

Let me know