Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Mateus Getulio 1 month ago.

Assigned support staff: Mateus Getulio.

Author Posts
April 27, 2021 at 2:27 pm #8636275

renaR

This site use to show up in Hebrew: hidden link Now it is only in English.

All the Author names on the site are now only showing up in English. I needed to shut off and turn on plugins. It happened after that.

April 27, 2021 at 4:01 pm #8637469

renaR

They are translating it with wpml string translations

April 28, 2021 at 12:26 pm #8644435

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I'll be happy to assist you with this.

Thanks for your update, but what we’re really looking for is how this content is added/edited in the main language. Please review this information and let us know.

In the meantime, let's follow some procedures to try to locate those strings. Firstly, test these steps:

- Please go to WPML -> Theme and plugins localization
- Select all plugins in the list and click on "Scan selected plugins for strings"
- When that finishes, select your theme in the other list and click on "Scan selected themes for strings"
- Now go to WPML -> String Translation and search for one of the items you couldn't find to translate and see if it will display now

If that doesn't work, please try to enable the option "Look for strings while pages are rendered" in WPML -> String Translation. Then visit that page in which the widget is located and go back to the String Translation, refresh the page and check if you'll be able to locate the strings now. (Please don't forget to uncheck the option "Look for strings while pages are rendered" once you're done).

Another attempt is to search for those strings in the "Translate texts in admin screens" section of String Translation. To do that, please follow these instructions:

- Go to WPML -> String Translation and click on "Translate texts in admin screens" at the bottom of the page
- Search for one of the items you can't translate
- Select that string and include it in the String Translation
- Go to WPML -> String Translation and search now for that item and see if it will display now for translation

If it doesn't solve the issue, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 5, 2021 at 6:23 pm #8698003

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

We're having a hard time trying to regenerate the MO files.

We believe we're getting this error due to a lack of permission on the wp-content/language and wp-content/language/wpml folders.

We tried to login into your FTP server to check this, but it seems like the FTP credentials aren't correct.

Can you please make sure that the FTP details access are correct?

I’m marking your next message as private again in case you need to send us confidential data.

Also, can you please create a folder language inside the directory wp-content and then a folder named wpml inside the language. Afterward, make sure that both folders wp-content/language and wp-content/language/wpml have their permissions set as 755.

Thank you, please let us know.

May 6, 2021 at 6:34 pm #8708285

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I checked this out but so far I couldn't find a fix for it.

I asked my colleagues to have a look at this issue in order to see if there's anything I'm missing.

I'll come back here as soon as one of my colleagues reply back to me (which it shouldn't take long).

Thanks,
Mateus.

May 6, 2021 at 8:05 pm #8708841

renaR

Thanks for your continued support

May 7, 2021 at 7:30 pm #8716673

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I have escalated this ticket to our 2nd tier of support where our 2nd tier specialists will take a deeper look at this issue and will try to find a solution.

I will get back to you as soon as I get an answer from them.

Best regards,
Mateus

May 9, 2021 at 6:28 am #8722375

renaR

Thanks

May 10, 2021 at 4:23 pm #8732045

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thanks for your patience.

Upon further inspection, our team could find a solution for the generation of the .mo files. We just reinstalled the WPML core plugin, commented the line "define( 'DISABLE_WP_CRON', true );" on the wp-config file and renamed the folder "language" to "languages".

Now, about the initial issue of this ticket, we've also found a solution after perceiving that the English strings were registered as Hebrew actually. So what we need to do is to change the language of these strings to English. We just followed these steps:

- For example, for the author string "Dr. Tsilla Hershco", hidden link
- Searching for it in the String Translation screen, we selected it under the domain "Authors", clicked on "Change the language of selected strings" and choose "English"
- After this, the author's name in Hebrew could be displayed correctly. Please check: hidden link. Also, on the Researchers page: hidden link

So, in summary, you have to do it for each "Authors" string. To save time, you can do it in bulk, selecting all strings under the domain "Authors" and then change their language to English. Please see the screenshot: hidden link.

Could you please follow these instructions? Let me know if they're clear to you.

Kind regards,
Mateus.

May 10, 2021 at 5:22 pm #8732219

renaR

Hi Mateus,

I tried changing the language of a couple of authors, but it didn't work for me. You can see them here:

hidden link

They are still in English. Is there something else that I am supposed to do?

Thanks!
Rena

May 10, 2021 at 6:25 pm #8732529

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Rena,

Thanks for your reply.

The strings from the screenshot you shared are missing translations - for example "Dr. Doron Matza" and "Oded Broshi". If you add their Hebrew translations, you still can't see them on the front-end?

Please let us know. Thank you,
Mateus.

May 10, 2021 at 6:42 pm #8732559

renaR

Those names looked like these in the backend:

hidden link

Then I switched their language to English. Where their translations lost when I did that? I thought I was supposed to do that.

Thanks,
Rena

May 10, 2021 at 8:51 pm #8733269

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Do the translations get lost when you change them to English? Could you please record a video showing this issue? You can use the Loom platform to do that: hidden link.

Or, if you prefer, please explain to us the exact steps to reproduce it. We're looking forward to your reply.

Best,
Mateus.

The topic ‘[Closed] Translate author info’ is closed to new replies.