Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Lauren 1 year, 9 months ago.

Assigned support staff: Lauren.

Author Posts
February 1, 2019 at 7:03 pm #3153013

simonP-14

I am trying to: I have basic words translated to Slovenian

Link to a page where the issue can be seen: hidden link

I have the language set to Slovenian, I see woocommerce-sl_SL.po and .mo in the language pluginn folder.
But the translation is not happening...

February 1, 2019 at 8:59 pm #3153217

simonP-14

I would just like to add that I think we managed to mess the contact form in the process... now it is not showing, nor the woocommerce items on the first page...
hidden link

February 4, 2019 at 2:34 pm #3158076

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I don't see how the import process could have removed the contact form, unless there is a memory limit issue. If that was the case, you should see an error in the debug log related to memory. If you deactivate WPML, does the contact form appear? If so, please open a new ticket for this issue specifically so that we can further investigate.

As for the import, I was able to successfully import a .po file to a different domain on a test site. Also, the translations that were imported were checked as translated by default. So, you should be able to successfully import the WooCommerce strings to your theme domain. Please make sure you are importing a .po file and not a .mo, and that you have checked the box to include the translations. If it still is not working, I suggest deactivating all non WPML plugins and trying to run the import again. Please let me know the results.

February 10, 2019 at 4:23 pm #3179968

simonP-14

Hi Lauren,

I made a new contact form, so it is not an issue, but I still cannot import the .po files.

I deactivated all plugins bit the four from WPML, and I still get the same errors... Forbidden when I try to import Avada-sl_SI.po and 404 when I try to import woocommerce-sl_SL.po ...

I have also updated to latest versions of wpml and the theme...

If you could help and sort it out I can give you the login details...

Thanks, Simon

February 11, 2019 at 3:51 pm #3183938

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Please also send me a link to download the files that you are trying to upload unsuccessfully.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

February 12, 2019 at 4:19 pm #3189760

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks so much for sending the files. I was able to upload them without any problem on a clean install. Please feel free to look and test anything here:
Login: hidden link
Username: demo
Password: lbGr12aBJ3D9

It could be a conflict with another plugin, or a server error causing the issue. Please ask your hosting provider to check the server logs and let me know if there are any errors. Additionally, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, are you able to import the files??

February 12, 2019 at 4:56 pm #3189923

simonP-14

Hi Lauren,

I have tried also deactivating all the plugins expect wpml, and changing theme to twentynineteen. Same error.
Here are the server error logs...
hidden link
hidden link

Let me know if find anything...

February 12, 2019 at 6:25 pm #3190366

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

I have sent you a private reply previous to this one. Please check that and let me know when the migration is complete. Thanks!

February 12, 2019 at 7:06 pm #3190469

simonP-14

Sure, no problem.

There was no option to write Database Username & Database Password.
hidden link

But I successfully finished the migration.

February 12, 2019 at 8:13 pm #3190661

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thanks for letting me know it was migrated. I was also able to upload both .po files to the cloudways test site without any issue. I added them both to the Avada theme and you can see on the staging site there are now over 8000 strings in Avada, whereas before there were a little over 3000.

Since we can't reproduce on staging or on a local copy of the site, I'm guessing there must be something server related to the issue. Could you please get in touch with your hosting provider and have them check on their end if something might be causing the problem? Perhaps it is timing out, since there are so many strings in the .po file? Or maybe there is a file size limit or something?

February 13, 2019 at 8:37 am #3192550

simonP-14

Hi,
I contacted the hosting provider and they found out that it was a module called ModSecurity hidden link that was blocking the import.
They turned it off and now it was completed successfully.

Thank you for all your help!

February 13, 2019 at 2:34 pm #3194652

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Great news! I'm glad they were able to find the cause of the issue. Have a great day!