This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 10.26 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I can't translate the cookie notice from the same name plugin ( Author: Dfactory)

Solution:
Please install Translation management, go to WPML > Settings > Custom XML Configuration.
Add there the following code and then find the string in WPML > String Translation

<wpml-config>
    <admin-texts>
        <key name="CookieLawInfo-0.9">
            <key name="notify_message"></key>
        </key>
    </admin-texts>
</wpml-config>

Relevant Documentation:
https://wpml.org/documentation/support/language-configuration-files/

This topic contains 14 replies, has 2 voices.

Last updated by Alejandro 3 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
July 2, 2019 at 7:15 am #4124541

adrianF-9

I change the message of the Cookie Notice Plug-in and I wanted to translate it into Spanish.

I used the Pluing WPML String Translation to translate it but I could not find the text to translate.

So, how can I translate the cookie notice message box which appears once you enter to the website?

Regards,

July 2, 2019 at 7:18 am #4124549

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

It's possible that the filed for the text is not registered, so that's why it doesn't appear in String Translation.

Could you please upload the plugin in this sandbox site and tell me where can i find the text?
--> hidden link

I'll proceed to check it out and try to find the field (and register it) for you.

Regards.

July 2, 2019 at 7:24 am #4124617

adrianF-9

Hello Alejandro!

Thanks for you quick and nice reply.

Ive already installed and activated the plugin.

I upload a picture where I show you the text I want to change.

I also realise that the text that appears on the WPML String Management Plug in is the default text, not the one I changed.

Thanks,

July 2, 2019 at 1:38 pm #4127433

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I tried checking if there was something wrong and it seems there wasn't. in fact i found the string in the String Translation page.

Try searching for it by filetering the results by domains. the domain for the string is "Cookie Notice" and check if you can find the cookie notice text there

Let me know how it goes.

July 2, 2019 at 2:06 pm #4127667

adrianF-9

I did as you said and I could not find the text Im looking for.

I show you a picture of what I see.

Maybe I should do something to update the strings.

July 2, 2019 at 4:03 pm #4128603

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

You need to search for the actual text. in this case use the entire text or just a piece of "This website uses cookies".

"Cookie Notice" is a filter item, which you can find in the domain filter, as shown in the screenshot below.

Let me know how it goes.

July 3, 2019 at 7:21 am #4132577

adrianF-9

I looked manually into the cookie-notice domain and I didnt find the sentence to translate.

Also, I did use the search engine as you said and It did not appear as shown in the picture attached.

July 3, 2019 at 12:05 pm #4136029

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Can you please give me access to your site so i can take a closer look?

Please add them in the fields i just activated for you, which are private and secure.

Regards.

July 3, 2019 at 3:26 pm #4137861

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm not sure why the string wasn't registered automatically as it happened in the sandbox but i registered it for you by installing "Translation Management" and then adding the following code to WPML > Settings > Custom XML Configuration:

<wpml-config>
    <admin-texts>
        <key name="CookieLawInfo-0.9">
            <key name="notify_message"></key>
        </key>
    </admin-texts>
</wpml-config>

If you don't want to have translation management, you can read this file and understand how to manually add the code to your plugin's XML file: https://wpml.org/documentation/support/language-configuration-files/

Regards.

July 3, 2019 at 3:27 pm #4137863

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

By the way, you can now find the string in WPML > String Translation.

Regards.

July 3, 2019 at 3:36 pm #4137963

adrianF-9

Honestly, my website does not work pretty well when I use every WPML plugins, thats why I do not use all of them all the time. I usually use WPML Management and then I deactivate it.

How can this affect to my website?

I realise that some of my pages does not have the hreflang code right.

July 3, 2019 at 3:49 pm #4138031

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I activated translation management mostly so i can add the XML code i sent you above in a "permanent" manner that wouldn't disappear when the plugin (WPML or the actual cookie notice plugin) got updated.

But you can modify the code to add it manually to maybe a child theme if you don't want to have translation management active.

About the hreflang code, you can leave a reply exclusively for that problem so i can split the ticket and take a look at that if you want.

Regards.

July 3, 2019 at 3:56 pm #4138051
adrianF-9

Please. I also need help with the hreflang code.

The code does not appear on the urls:

hidden link

hidden link

New threads created by Alejandro and linked to this one are listed below:

https://wpml.org/forums/topic/hreflang-issue-2/

July 4, 2019 at 6:42 am #4140503

adrianF-9

Good morning Alejandro,

Please, tell me once you open a new ticket.

Meanwhile, I will try to fix the code manually, adding the hreflang code left.

Regards,

July 4, 2019 at 8:21 am #4141173

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, i already split the ticket and asked you a few questions. I'll proceed to close this ticket since it's already solved.

Regards.