This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Andreas W. 3 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 20, 2019 at 1:50 pm #4060467

Menno

Hi WPML support,

I'm trying to build a multi-language job site with Toolset and WPML. I created this so far hidden link and i would like to translate it to this page hidden link. I searched on String Translation and translated the slug but the url isn't working..

Any idea how to solve this?

Thanks,
Menno

June 21, 2019 at 12:17 am #4063673

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Please go to WPML -> Settings -> Post Type Translation and make sure that the post type is set to "translatable".

Then go to the ection "Slug translation" and enable this option. If you now scroll back to the post type translation section you should see an uption to translate the slugs for each custom post type.

Here the full documentation:
https://wpml.org/documentation/getting-started-guide/translating-page-slugs/

I hope this solved the issue.

Kind regards
Andreas

June 21, 2019 at 6:45 am #4064947

Menno

Hi Andreas,

Yes i did that but i can only translate the singular / single post slug: hidden link

I would like to translate the archive: hidden link or hidden link

I used string translation but the url gives a 404.

Thanks, Menno

June 21, 2019 at 10:13 pm #4069347

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

June 24, 2019 at 10:04 pm #4080009

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I realized that the URL hidden link ends into a wrong archive page once clicked on its link.

It seesm the issue was solved after simplz resvaing the permalinks at Settings -> Permalinks.

I was not able to verify as you did not include the WPML language switcher yet. Take note that you can activate anz language switcher for testing reason and use the option WPML -> Languages - Hide language, in order to hide the Dutch language for all visitors until the site is ready.

I hope this solved the issue. Let me know if you need further assistance.

Kind regards
Andreas

June 26, 2019 at 12:04 pm #4092265

Menno

Hi Andreas, the slug hidden link works now! I think resaving the permalinks did the job :).

Thanks,
Menno

June 26, 2019 at 4:28 pm #4094065

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi Menno,

Thank you for letting me know. I am glad to hear that the issue is solved.

Feel free to reach out again in case you need further assistance.

Kind regards
Andreas