This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by Mihai Apetrei 3 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 27, 2019 at 3:10 pm #3898909

giovanniB-19

Hi,
before with loco translator, I was able to translate even the default language, in this case, English. but now with WPML i dont know how to do it.
For example, for the purpose of my website, the "Vendor" string is translated in "Chef" in both languages, but it appears still as default in the English version. see pic attached.

I also tried to translate the message under the woocommerce registration form without any success.
Thanks
giovanni

May 29, 2019 at 11:13 am #3914693

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

WPML is built in a way where it can be used to translate the default language into many other languages (https://wpml.org/faq/string-translation-default-language-not-english/) but it is not thought to be used to translate the original/default language.

From my understanding, you are saying that the default language is English and the secondary is French so you could try to switch the language of the string as shown in the solution from the link below and then translate the english one to how you like it.
https://wpml.org/forums/topic/how-to-change-string-language-selection/

Please let me know if that works.

WPML is not thought for translating the default/original language strings so this might not work.

I would be also happy to take a look if you want, just to make sure so I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 31, 2019 at 12:23 pm #3930425

giovanniB-19

Regarding translating the default language, i have tried to switch the language of the string from English to French and translate the English string, as shown in the solution from the link you gave to me. it works, but the French string will turn in English. so basically i did not solve the problem.

there is no way to make loco translate as the main language, or something similar?
because i have basically all the strings already translated in Loco plugin, which they actually appear on the French version, but not in English. it seems like English show only default one.

As you can see on the attached pics, the French translation is coming from loco translate, but WPML does not recognize English version translation from loco translate plugin, and they show as default.

May 31, 2019 at 3:30 pm #3931733

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Can you please try the solution in the link below and let me know if it works for you?
https://wpml.org/forums/topic/combining-poedit-files-with-string-translations/#post-1455458

I will be waiting for your response.

Please let me know how that goes and if it solves your issue.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

June 4, 2019 at 7:59 am #3948949

giovanniB-19

Hi, Mihai.
Yes it worked out! thanks a lot!
But i still have some strings not translated.
For example, on the vendor dashboard in Eng version, everything is in English apart from the attributes on the dropdown box and some strings, under the Attributes tab.
Also, attributes will become in English on top of each attribute box, but shows as French on the dropdown box.
please have a look to the attached pic.
Also, did you have time to login on my website?
thanks a lot
Giovanni

June 5, 2019 at 1:39 pm #3960919

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Giovanni!

Welcome back.

I am glad to hear that the solution worked.

Now, regarding the strings that are still not translated, can you please let me know the exact steps I would need to follow in the backend of the site so that I can get to the page you are showing me in the screenshots?

Also, can you please let me know where are those strings and vendor functionality coming from? It is coming from a plugin or theme that you use?

Please let me know.

I will be waiting for your response.

Kind regards,
Mihai

June 7, 2019 at 2:52 pm #3977241

giovanniB-19

Hi, thanks for your reply.
You can login as a vendor, I can give you the credentials on private message if you would like.
the strings are from WC Market place i guess.

June 7, 2019 at 5:04 pm #3978097

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

That sounds good.

I will enable the private fields below for the credentials.

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

June 13, 2019 at 3:38 pm #4014703

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they worked.

I will spend some time on this and I will get back to you as soon as I have any feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

June 14, 2019 at 8:35 pm #4024033

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

I spent some more time on this panel but I am not sure that I am able to follow the steps that you shared. Everything seems to be translated in French and I went to a few wrong places already.

I am attaching a screenshot with the panel that I see.

Can you please let me know what would be the exact process I would need to follow to get to the place you showed me in your last screenshot?

Please let me know.

I will be waiting for your response.

Kind regards,
Mihai

June 15, 2019 at 5:52 am #4025663

giovanniB-19

Hi. Thanks for your reply.
You should login with English language selected. Make sure you choose English before login, otherwise when you are on chef dashboard you can go back just by clicking on sootasty logo and change the language
Thabks a lot
Have a good day

June 17, 2019 at 10:15 am #4034347

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Mihai is off for the day, I will handle this ticket during his absence, I hope thats okay with you.

After checking the entire thread it seems you are now stuck with a mixed translation, to resolve this please follow the steps.

- Backup your site and database, Before you proceed
- Goto WPML > Support > Troubleshooting (check attached screenshot)
- Click on the following buttons
- Clear cache with WPML
- Fix terms count
- Recreate ST DB cache tables

However, using Loco translate along with WPML might cause some issue like mixed content. Temporarily disable loco translate check if the issue is resolved.

Please share the results.

Kind regards
Raja

June 25, 2019 at 1:38 pm #4084989

giovanniB-19

hi, i disable loco plugin, and followed your steps. the problem still persists.
thanks

June 26, 2019 at 3:14 pm #4093521

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am back. Thank you for your patience and I am sorry to see this has not been solved yet.

I will spend a bit more time on this and see if there's any way I can get things working for us.

If that won't work still, I will create a clean environment and I will need you to reproduce the issue on our servers as we might be dealing with a compatibility issue.

I will get back to you as soon as I have any feedback regarding this.

Kind regards,
Mihai

June 27, 2019 at 3:09 pm #4101155

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

So I figured out that the link I need to get in the end in order to see the ENGLISH version of the vendor dashboard is this one: hidden link

So I loaded it and for me, everything looks ok and fully in English.

I don't see French words like the ones you attached in the screenshot.

Maybe you have your browser set in French or maybe you are seeing a cached version?

I am attaching some screenshots, too so that you can see what I see.

Please let me know what do you think (maybe try logging in from another computer or from a browser that is set on English).

Kind regards,
Mihai