This thread is resolved. Here is a description of the problem and solution.

Problem: In our other languages like Italian or French, the shop page only shows one product instead of 3.

Solution: Make sure products were are translated correctly and 100%. In this case, the slug was not translated, so the product "didn't" exist.

Relevant Documentation: - https://wpml.org/documentation/related-projects/woocommerce-multilingual/#products

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by patrickK-9 1 month, 1 week ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
June 2, 2020 at 6:58 am #6270565

patrickK-9

Hi. Hope you are fine
Please go to hidden link
You will see that we have implemented on the left side a category filter and a price filter widget. It works all fin in the default language (English), but in our other languages like Ialian or French, it only shows one product instead of 3.
Before adding all the products I would like to make sure that those widgets can work in the other languages (BTW, I have translated all the categories in the WPML Woocommerce plugin)
Thanks for your help.
Kind regards

June 3, 2020 at 11:31 am #6282601

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

1) Make sure to have translated products to 2nd language. From debug provided, I think you have set in WPML>Settings the product as a fallback to default if translation don't exist. If there is no translation, the product can not be shown in the translated store.

Info: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

2) Go to the WooCommerce -> WooCommerce Multilingual page, you will start on the Products tab. Make sure to have product translated and check if they show up after translating. It only shows that 1 product, since that one is only one translated.

Info: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#products

Please let me know how it goes.

Regards,
Drazen

June 3, 2020 at 12:42 pm #6283663

patrickK-9

Hi Drazen,
thank you for getting back to me.
Unfortunately I was aware of your point 1 and point 2.
I have not translated all the products but have translated 3 of our products in the 2nd and 3rd language. The problem it really shows only one product instead of "3", please see the 3 products that were translate with Woocommerce multilingual page. and please help. Kind regards Patrick

June 3, 2020 at 12:59 pm #6283869

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the feedback and images.

that is weird, in page source it is not showing translation and the product "translation" leads to 404 pages.

In order to investigate this issue and to understand it better, I would need to access your website.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the private fields mentioned.

You can safely add your information into these fields.

Thanks,
Drazen

June 3, 2020 at 2:55 pm #6285065

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I have checked your website, it seems products were not translated correctly. You will need to translate everything 100%. In this case, the slug was not translated, so the product "didn't" exist.

After translating slug and saving, the product shows correctly and language switcher on a product works fine.

Please check and make sure all products are 100% translated. Please check the images attached.

Please let me know how it goes and don't hesitate to ask if you find any problem along the way or have doubts or questions.

Regards,
Drazen

June 3, 2020 at 5:30 pm #6286191

patrickK-9

Thank you, and yes, I can see that by tranlating the slug you have added the product to show in French. But still I don't understand what I should now do with all the other products.
The process I used was to go to menu Woocoomerce/Woocommerce multilingual, and then click on one of the product language icon to open the advance translator and translate the product. Still if I do like that I can't find where and how to modify the slug that is not translated. Please explain to me what you suggest as a process to translate all of the other products so that it will translate the slug or how to do that manually.
for example I can't find where to click to get to the page of your screenshot_4.jpg where you change the slug.
Thanks for your help
Kind regards

June 3, 2020 at 5:53 pm #6286465

patrickK-9

BTW, I think I found something. In the "All products" menu, I saw that for my other languages, draft products had been created for products that I did not even translated through the Woocommerce Multilingual menu. Those draft products in other languages were created probably because when I create a new product I duplicate an existing product. I have now deleted all the drafts and now I can see one more t-shirt in the french website. I will try to translate other products with the advance translate editor to see if that works now.

June 3, 2020 at 6:28 pm #6286627

patrickK-9

Hi,
I can confirm that in my case it works now. SLUGS are now also translated by the Advance editor. So in my case I need to go to "All products" and make sure to delete all the drafts, then also make sure to remove definitively the drafts from the trash. After that, I can go into the woocommerce multilingual menu and translate the products with the Advance editor. Once all is translated (100% green) and that I save the translation, the product now appears automatically in the other languages.
Many thanks again for your help. I will close the ticket since it's all working now.
Kind regards

June 3, 2020 at 6:29 pm #6286635

patrickK-9

My issue is resolved now. Thank you!