This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 2 voices.

Last updated by aliA-44 3 months ago.

Assigned support staff: Bruno.

Author Posts
June 24, 2019 at 8:12 am

aliA-44

Tell us what you are trying to do?

i am trying to translate header title but it's not working

Is there any documentation that you are following?
yes all of it

Is there a similar example that we can see?
yes

What is the link to your site?

aqdar.ae

June 24, 2019 at 10:09 am
June 24, 2019 at 10:11 am #4076277

aliA-44

hello it's kick me off ! i did not complete reading

June 24, 2019 at 10:31 am #4076497

aliA-44

Welcome to Cloudways!
The migration process of your website(s) is underway. Generally, the migration can take up to 4 hours to complete. The Cloudways Platform has been optimized to work flawlessly with all kinds of WordPress websites.
The time to complete the migration depends entirely on the size of your site. Therefore, your migration may take shorter or longer than the average duration. Once your migration is complete, we will inform you via email. you will receive a confirmation email informing you of the successful transition
If you want to track live progress of your migration

June 24, 2019 at 10:45 am #4076631

aliA-44

hidden link

done

June 24, 2019 at 4:27 pm #4078639

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I would be very happy to help you but I didn't fully understand what is the issue.

When I access your site and click to see the translation, I see that the part you have highlighted is not translated. Am I following some steps incorrectly? I'll attach an image for you to see.

I'm not sure if that's what you're talking about or if it's something else.

Thank you.

June 25, 2019 at 4:25 am #4081263

aliA-44

correct I can not translate the Header title of the page

let me know if need something i will be online next 8 hr

Thanks

June 26, 2019 at 10:14 am #4091355

aliA-44

Hi,

sorry i am bother you, there is any update ?

June 27, 2019 at 1:48 am #4095485

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sorry for the delay. I believe the problem may be happening because WPML Translation Management is not installed.

Please, could you install WPML Translation Management to see if the problem persists? If the problem persists, please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

June 27, 2019 at 5:10 am #4096617

aliA-44

Hi,
we already know what the problem and Mr. Itamar he ask for cloudways to do this test if we can do it without delete or lose the content

thanks

June 28, 2019 at 12:49 am #4103281

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

I'll contact Itamar to verify this. Soon we will contact you.

Thank you.

July 1, 2019 at 5:16 am #4115631

aliA-44

Hello,

Any update ?

July 2, 2019 at 8:58 pm #4130037

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sorry for the delay. I was able to replicate the problem you are reporting. This is happening because of your theme. In your theme, the author is defined as the content of the "Header" to be synchronized between the languages. You should follow the steps below:

- Backup your site;
- Install the WPML Translation Management
- Click on the WPML > Settings > Custom XML Configuration
- Insert these lines:

<wpml-config>
    <custom-fields>
        <custom-field action="translate">_bunch_header_settings</custom-field>
    </custom-fields>
</wpml-config>

- Click on the Save button
- Go to the desired page
- Click on the Update button
- Click to edit the translated content
- Insert the desired header and click on the Update button

By following the steps below this worked correctly in my testing environment. I have not tested this on your server, but following these same steps the problem should be solved and you can update the contents of the header.

Please, follow the steps above, let me know if you can edit the content you want.

Thank you.

July 7, 2019 at 5:01 am #4157121

aliA-44

Hello

thanks for your helping,

- Install the WPML Translation Management,

as you know we need to delete the plugin and install it again, is this well delete all content

thanks

July 10, 2019 at 6:10 pm #4183571

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

>>> as you know we need to delete the plugin and install it again, is this well delete all content

Sorry, but I did not understand. Installing WPML Translation Management should not cause loss of content or remove other plugins. Why would I need to remove other plugins?

If I have not understood what you are talking about, could you please elaborate a little more?

Thank you.