Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by aileenJ 1 month ago.

Assigned support staff: Mihai Apetrei.

Author Posts
January 22, 2020 at 11:05 am #5339845

aileenJ

> Tell us what you are trying to do?
Trying to translate my homepage into french. But instead of having the example.com/fr url, WPML creates the example.com/fr/home url. How can create the homepage translatioun without the /home slug?

>Is there any documentation that you are following?
No

>Is there a similar example that we can see?
No

>What is the link to your site?
byjaco.com

January 22, 2020 at 11:47 am #5340247

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

That's pretty weird.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

January 22, 2020 at 4:26 pm #5342779

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for the credentials.

I can confirm that they work.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

January 23, 2020 at 2:25 pm #5350085

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for your patience.

I tested the homepage from your site (I created just a test translation which you can see here: hidden link) and it seems that it works and there's no slug or extra word added in the link.

Can you please let me know what are the exact steps that I should follow to reproduce the exact issue? Or has this been resolved already?

Please let me know.

Kind regards,
Mihai

January 27, 2020 at 3:17 pm #5370829

aileenJ

Hi again. well thats weird because when I push the + button for the home page, then there is an additional word in the URL.
thanks for your help

January 27, 2020 at 3:22 pm #5370843

aileenJ

I just tested it again. and works. Thank you

January 27, 2020 at 4:39 pm #5371701

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

That's great to hear! I am happy for you 🙂

Can you also please mark this current ticket as resolved, too?

Thank you.

Kind regards,
Mihai

January 27, 2020 at 7:13 pm #5372187

aileenJ

My issue is resolved now. Thank you!