This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I cannot translate widget "widget_wp_store_pro_promo".

Solution:
I have enabled widget's string translation using our XML config method and added following XML code:

<wpml-config>
    <admin-texts>
        <key name="widget_wp_store_pro_promo">
            <key name="*">
                <key name="promo_title"/>
                <key name="promo_desc"/>
                <key name="promo_link"/>
                <key name="promo_btn_text"/></key>
        </key>
    </admin-texts>
</wpml-config>

In WPML >> Settings >> Custom XML Configuration section and now widget is translating using string translation.

Relevant Documentation:
https://wpml.org/documentation/getting-started-guide/translating-theme-options/

This topic contains 7 replies, has 2 voices.

Last updated by vasiliyM 1 year ago.

Assigned support staff: Noman.

Author Posts
October 5, 2018 at 9:58 am #2790266

vasiliyM

It is additional question to https://wpml.org/forums/topic/translate-html-inside-template-and-slider/

I did the same String Translation in another place of Template. All string were found and translated, but it does not work.

What could it be?

October 8, 2018 at 11:29 am #2795806

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb, I suggest to change it to 256Mb: https://wpml.org/home/minimum-requirements/

Could you please try to re-save the translation:

1. Go to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

2. Then again go to: String Translation >> Re-add your translated text >> and re-save. Make sure that "Translation is complete" checkbox is selected.

3. Please delete all sort of caches on your site / server cache if any / plugin cache / CDN cache (if any), clear browser cache and then see if it resolves the issue afterwards. You can also disable cache plugin temporary while you update this string.

4. If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add backend link where I can see the issue.

Thank you

October 8, 2018 at 12:20 pm #2795952

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

[ changing ticket status ]

October 9, 2018 at 8:37 am #2798957

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have tried to login to your site but it’s redirecting me to this my-account( hidden link ) page. Could you please provide me admin level access so that I can see wp-admin back-end of your site and fix this issue. I have enabled private input box for your next reply.

Thank you

October 9, 2018 at 8:39 am #2798960

vasiliyM

Fixed

October 9, 2018 at 8:44 am #2798965

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks. It's working now.

October 9, 2018 at 9:56 am #2799287

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have enabled widget's string translation using our XML config method and added following XML code:

<wpml-config>
    <admin-texts>
        <key name="widget_wp_store_pro_promo">
            <key name="*">
                <key name="promo_title"/>
                <key name="promo_desc"/>
                <key name="promo_link"/>
                <key name="promo_btn_text"/></key>
        </key>
    </admin-texts>
</wpml-config>

In WPML >> Settings >> Custom XML Configuration section and now widget is translating using string translation. Could you please check and confirm?

Thank you

October 9, 2018 at 9:59 am #2799325

vasiliyM

My issue is resolved now. Thank you!