This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by Andreas W. 3 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 10, 2019 at 11:17 am

bramD-2

Hi,

I installed the sticky links plugin to translate in page links to refer to translated content, but this does not seem to work. I already had 2 chats concerning this, but this did not get resolved.

I did the scan and no broken links were found, which is correct because they all work. The only problem is that when you are on a french page, the link is pointed to english content. So, it is not broken, just not pointing to the right language.

Please advice on this.

Thx

June 10, 2019 at 12:16 pm
June 10, 2019 at 11:41 pm #3990733

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have added some markup at WPMl -> Settings -> Custom XML Config.
https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

The link URLs for the section are now available when translating the page again.

I hope this solved the issue.

Kind regards
Andreas

June 11, 2019 at 8:03 am #3993097

bramD-2

Hi Andreas,

I was able to do this for the german language. But I got a different view there of the ATE. All fields are below each other, while on the other pages I have to click on a text first.

What is the difference. On the image with capture.jpeg I can translate the links, on the other languages not.

Do I need to make a scan or do something else?

Thx

June 11, 2019 at 5:57 pm #3997901

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Can you confirm that the translation worked, if you use the Classic Translation Editor?
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

If the links indeed do not show up on the Advanced Translation Editor then we might test if there is an issue.
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Could you please install the theme and any necessary in order to recreate the issue on the following test site?

One Click Login: hidden link

Please leave me a short notification once the site is ready for testing.

Kind regards
Andreas

June 11, 2019 at 6:21 pm #3998045

bramD-2

Yes, that is correct.

I uploaded the theme to the sandbox environment. I could also setup one on my server with a copy of the site, if that would be more convenient. Let me know.

Why do I get on that translation the classic editor and on the other languages of the same page the advanced one? Just to know.

Thx

June 12, 2019 at 11:05 pm #4007851

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have been investigating the issue on the sandbox using the upcomming version of WPML Multilingual CMS 4.2.7 and there was not any issue translating the content with the Classic Translation Editor.

It was not even necessary to include a custom XML config. Everything should up as expected.

I would like you to have some more patience as I will need to migrate the site to our test server in order to test it with the Advanced Translation Editor.

Further, could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Also enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to see errors on front end, backend and further find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

I would kindly like to ask you for some more patience. I will be in contact tomorrow.

Kind regards
Andreas

June 13, 2019 at 7:15 am #4009847

bramD-2

Hi Andreas,

indd the translations of the links work with the classic editor. It is the advanced editor that gives the issues of not showing these links.

Can I revert my site to the classic editor for now? Or is that not done?

Thx

June 13, 2019 at 4:53 pm #4015789

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In case you consider to switch the Translation Editor, please make a backup of your site and database before changing the setting back to the Classic Translation Editor, as in some cases it might cause that content can get lost when switching the Editors.

I have now migrated the Duplicator copy to our test server and tested the translation with the Advanced Translation Editor. The translation of the Salient WPBakery Page Builder element Custom Heading worked here without issues.

You can see the test here:

hidden link

User: andreas

Password: support

It seems there might be another issue on your site. Pleas emake sure that all plugins are up-to date.

Further, could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 512M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000.
You can find the php.ini file on your server inside the folder for your currently used PHP version 7.2.18.

In case of any doubt please contact your hosting provides and ask for assistance.

I hope this will solve the issue.

Kind regards
Andreas

June 13, 2019 at 6:30 pm #4016361

bramD-2

Hi Andreas,

will look for the memory.

The element I was trying to translate is "Column Link". I did not find this in your setup.

I added this to the sample page. I tested this with the classic editor and with the xml and this works. I tried to convert to the advanced editor, but I can not get that working.

You can check this on the "Sample Page"

Thx already!

Cheers

June 13, 2019 at 9:56 pm #4017093

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the clarification.

I realized the issue now and found a solution by chaning the attribute:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>vc_column</tag>
            <attributes>
                <attribute type="link" encoding="av_link">column_link</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

After applying the custom XML config please make sure to update the page and translate it again with ATE. The column link should work afterwards.

Thank you!

Kind regards
Andreas

June 14, 2019 at 9:48 am #4020049

bramD-2

No, still does not work.

I pasted the code. Added a row, updated the page and then went to the translations.

Thx

June 14, 2019 at 10:11 am #4020407

bramD-2

The links in Dutch were pointing to the english page before. Now it appears to be broken. Scanning with sticky links does not help.

June 14, 2019 at 10:15 am #4020419

bramD-2

Produkte

Produkte

Markisen
markisen
hidden link
Smart Blocker
Smart Blocker
Markisenzelte
Fahrradträger
Einstiegsstufen
Dachträger und Leitern
Einordnen
hidden link
Dachhauben
Schlösser
Auffahrkeile
Thule_Catalogue_VAN_2019_V1_EN_Digital-PP_Page_01
Thule_Catalogue_B2C_2019_V1_EN_Digital-PP_Page_001
Spare Parts Excellent EX600-03
Der stabile Weg zum Parken.
Der stabile Weg zum Parken.
Thule_Strap_Lock_hero_307389
The innovative lockable strap prevents theft of your kayak or other equipment you strap on to your roof rack.
Provides storage space for all kinds of things.
Provides storage space for all kinds of things.
vent-translucent-fan_open
thule_van-roof-rack_PS_20161115_662
thule_slide-outstepv18-12V_20171202_001_nowire
Thule_Excellent_Black_Standard_Version_hero_302033_
Thule_Mosquito_QuickFit_hero_309925
thule_residence-g3_closed_PS_20160525_022
thule_studio_141022_R+SB_FicheA1-3-4
thule_tension-rafer-g2_PS_20160429_no-bg
thule_inside-out-lock-g2_PS_20161108_289_keys
Thule_Omnistor_6300_Manual_Box_White

This is what I see after translating. You can see there are two links to the english page now. But I do not see them in the Advanced translator.

For one reason or an other I have the Advanced translator again on the german page.

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>vc_column</tag>
            <attributes>
                <attribute type="link" encoding="vc_link">column_link</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

I also think it should be vc_link instead of av_link, no?

Everything combined, I think the advanced editor is really acting up on this one. So the cause might be there I guess.

Cheers

June 14, 2019 at 4:05 pm #4022957

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am so sorry, this was a type error. It should be vc_link for sure.

The vc_ stands for Virtual Composer, which is the original name of the WPBakery Builder.

The only trick was to add the properties to the attribute which are:

type="link" encoding="attribute_name"

By the way, you can see the tags and attributes for each shortcode by going to the page editor and instead of using the WPBakery Backend Editor switch to default editor.

Shortcodes are always wrapped into square brackets [shortcode]. What you see here between two similar shortcode tags are the attributes (Links, etc.).

I hope this solved the issue, as it worked on my test site.

Thank you!

Kind regards
Andreas